2 Replies Latest reply: May 16, 2012 5:58 AM by willfried matter RSS

installation problems

Jhonnathan Cardona Saineda Newbie

I'm installing jboss-eap-installer-5.1.2.jar, but at the time of the installation I choose HornetQ,

and when I choose: choice of WS stack, i choose WSNative, i get an error:

 

  1. install:
  2.      [echo] Preparing to install WS CXF
  3. [ Unpacking finished ]
  4. [ ERROR: The following error occurred while executing this line:
  5. /usr/java/jboss-eap-5.1/jboss-as/scripts/install-cxf.xml:8: Basedir /usr/java/jb                                                                                        oss-eap-5.1/jboss-as/jbossws-cxf-installer does not exist ]
  6. com.izforge.izpack.installer.InstallerException: The following error occurred wh                                                                                        ile executing this line:
  7. /usr/java/jboss-eap-5.1/jboss-as/scripts/install-cxf.xml:8: Basedir /usr/java/jb                                                                                        oss-eap-5.1/jboss-as/jbossws-cxf-installer does not exist
  8.         at com.izforge.izpack.event.AntActionInstallerListener.performAllActions                                                                                        (Unknown Source)
  9.         at com.izforge.izpack.event.AntActionInstallerListener.afterPacks(Unknow                                                                                        n Source)
  10.         at com.izforge.izpack.installer.UnpackerBase.informListeners(Unknown Sou                                                                                        rce)
  11.         at com.izforge.izpack.installer.Unpacker.run(Unknown Source)
  12.         at java.lang.Thread.run(Thread.java:662)
  13. Caused by: The following error occurred while executing this line:
  14. /usr/java/jboss-eap-5.1/jboss-as/scripts/install-cxf.xml:8: Basedir /usr/java/jb                                                                                        oss-eap-5.1/jboss-as/jbossws-cxf-installer does not exist
  15.         at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(Projec                                                                                        tHelper.java:508)
  16.         at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:418)
  17.         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  18.         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.                                                                                        java:39)
  19.         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces                                                                                        sorImpl.java:25)
  20.         at java.lang.reflect.Method.invoke(Method.java:597)
  21.         at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.jav                                                                                        a:106)
  22.         at org.apache.tools.ant.Task.perform(Task.java:348)
  23.         at org.apache.tools.ant.Target.execute(Target.java:357)
  24.         at org.apache.tools.ant.Target.performTasks(Target.java:385)
  25.         at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
  26.         at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
  27.         at com.izforge.izpack.event.AntAction.performAction(Unknown Source)
  28.         at com.izforge.izpack.event.AntAction.performInstallAction(Unknown Sourc                                                                                        e)
  29.         ... 5 more
  30. Caused by: /usr/java/jboss-eap-5.1/jboss-as/scripts/install-cxf.xml:8: Basedir /                                                                                        usr/java/jboss-eap-5.1/jboss-as/jbossws-cxf-installer does not exist
  31.         at org.apache.tools.ant.Project.setBaseDir(Project.java:819)
  32.         at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:324)
  33.         at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
  34.         at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
  35.         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces                                                                                        sorImpl.java:25)
  36.         at java.lang.reflect.Method.invoke(Method.java:597)
  37.         at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.jav                                                                                        a:106)
  38.         at org.apache.tools.ant.Task.perform(Task.java:348)
  39.         at org.apache.tools.ant.Target.execute(Target.java:357)
  40.         at org.apache.tools.ant.Target.performTasks(Target.java:385)
  41.         at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
  42.         at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(Single                                                                                        CheckExecutor.java:38)
  43.         at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
  44.         at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
  45.         ... 17 more

 

I am using Centos



  • 1. Re: installation problems
    willfried matter Newbie

    I have exactly the same problem.

     

    The most surprising thing is that I've been able to install it in graphical mode on a Linux Suse SLES 11.1 without problem.

    On a AIX 5.3.12.1 server, without access to a graphical x-windows console, ie installing in text mode, I have the same failure.

     

    I wonder if it is a problem of :

    1. OS, are there some supported operating systems listed by redhat?
    2. JVM, are there some "officialy adviced" JVM ?
      Biut I have a "IBM J9 VM" JRE 1.6.0 compliant, on both servers
    3. Bug in the text mode installer ?
  • 2. Re: installation problems
    willfried matter Newbie

    I finally succeeded  the installation in graphical mode,

    redirectiong the DISPLAY on the AIX server and using xming on my PC.

     

    My conclusion is : bug affecting the text installer.