1 Reply Latest reply: May 3, 2012 10:00 AM by Xinhua Gu RSS

mod_cluster1.2.0, mod_advertise question

Xinhua Gu Newbie

hi,

I tried to config a mod_cluster on a debian box , but failed. Every time when i start apache, i see a Warning in /var/log/apache/error.log,

 

[warn] mod_advertise: ServerAdvertise Address or Port not defined, Advertise disabled!!!

 

How can i fixe it?  here is my env info and configurations:

 

Debian 6.0.4

apache2.2.22-5

mod_cluster_1.2.0.final

 

/etc/apache2/mods-available/mod_cluster.conf

 

  <IfModule manager>
    Listen 127.0.0.1:6666
    ManagerBalancerName mycluster

     <VirtualHost 127.0.0.1:6666>
        KeepAliveTimeout 300
        MaxKeepAliveRequests 0
        AdvertiseFrequency 5
        ServerAdvertise On
        EnableMCPMReceive
        <Location />
            Order deny,allow
            Allow from all
        </Location>
          <Location /mod_cluster_manager>
                SetHandler mod_cluster-manager
                Order deny,allow
                Allow from all
        </Location>
     </VirtualHost>
  </IfModule>

 

/etc/apache2/mods-avaliable/mod_cluster.load

 

LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so
LoadModule proxy_ajp_module /usr/lib/apache2/modules/mod_proxy_ajp.so
LoadModule slotmem_module /usr/lib/apache2/modules/mod_slotmem.so
LoadModule manager_module /usr/lib/apache2/modules/mod_manager.so
LoadModule proxy_cluster_module /usr/lib/apache2/modules/mod_proxy_cluster.so
LoadModule advertise_module /usr/lib/apache2/modules/mod_advertise.so

 

/etc/apache2/sites-avaliable/jboss

 

#NameVirtualHost *:80
<VirtualHost *:80>
    #ServerAdmin info@domain.de
    ServerName  comitdev2
    ServerAlias comitdev2
    ProxyPass / balancer://mycluster stickysession=JSESSIONID|jsessionid nofailover=On
    ProxyPassReverse / balancer://mycluster
    ProxyPreserveHost On
      <Location />
        Order deny,allow
        Allow from All
    </Location>
  </VirtualHost>

 

then i started apache :

 

a2enmod mod_cluster
a2ensite jboss
service apache2 restart

 

apache started with the Warning and i can not access localhost:6666/mod_cluster_manager

 

any help would be appreciated,

thanks!


  • 1. Re: mod_cluster1.2.0, mod_advertise question
    Xinhua Gu Newbie

    Ah , i found the reason,  a misstake in /etc/apache2/mods-available/mod_cluster.conf


      <IfModule manager>

    "manager" is a wrong module name, so the followed settings were ignored by apache

     

    it should be

      <IfModule manager_module>

     

    advertise works now.

     

    hope this post can help others