13 Replies Latest reply: May 16, 2012 10:47 AM by rajivtmathew RSS

Configure Arquillian with Custom Jboss AS7

badr elhouari Novice

Hi,

 

I want to test the JSFUnit 2.0.0.Beta2 Getting Started Example with my preconfigured Jboss AS 7 (with Public IP and security realm domain) first :

 

i get the error:

"Could not connect to remote://localhost:9999 in 5000ms. Make sure the server is running and/or consider setting a longer timeout ..."

 

i've added a jndi.properties file in my ressource folder to specify my IP_ADR and jndi port ... but it doesn't work and the surefire repoted the same error, i guess it is still using localhost:9999

 

After i've read in https://docs.jboss.org/author/display/ARQ/Supported+containers that extra configuration in arquillian.xml is required for AS7 containers, and i've appliyed that following the documentation

https://docs.jboss.org/author/display/ARQ/JBoss+AS+7.0+-+Remote BUT also it doesn't work and the report still say "Could not connect to remote://localhost:9999 ..."

 

I've changed the IP_ADR to 127.0.0.1 and the report changed to:

"java.lang.Exception: {"Services with missing/unavailable dependencies" => ["jboss.web.deployment.default-host./test.realm missing [ jboss.security.security-domain.other ]"]}"

which is normal in my case since i use a security realm beside an ldap server. The problem reside even if i add the jboss-web.xml under WEB-INF with my domain:

 

<jboss-web>

     <security-domain>MyDomain</security-domain>

</jboss-web>

 

Any suggestions and helps are welcome

 

Thanks in advance

 

PS:The getting started example worked for me in a virgin JBoss7 (without any custom configuration)

  • 1. Re: Configure Arquillian with Custom Jboss AS7
    Aslak Knutsen Master

    For JBoss AS 7.0.1.Final:

     

    If you set the managementAddress configuration option to where the management api is bound, it should read out from the server where http/jmx etc ip/ports are bound.

  • 2. Re: Configure Arquillian with Custom Jboss AS7
    badr elhouari Novice

    I've do that first by configuring my jndi.properties file in ressource folder and second by following https://docs.jboss.org/author/display/ARQ/JBoss+AS+7.0+-+Remote

     

    but it doesn't work and arquillian report that it connect to localhost !!

     

    is there ayn suggestion about configuring arquillian with a remote jboss using JNDI

  • 3. Re: Configure Arquillian with Custom Jboss AS7
    Aslak Knutsen Master

    jndi.properties is not used.

     

    What does your arquillian.xml look like, and your standalone.xml ?

  • 4. Re: Configure Arquillian with Custom Jboss AS7
    badr elhouari Novice

    Standalone.xml


    <?xml version='1.0' encoding='UTF-8'?>
    
    <server name="localhost.localdomain" xmlns="urn:jboss:domain:1.0">
        <extensions>
            <extension module="org.jboss.as.clustering.infinispan"/>
            <extension module="org.jboss.as.connector"/>
            <extension module="org.jboss.as.deployment-scanner"/>
            <extension module="org.jboss.as.ee"/>
            <extension module="org.jboss.as.ejb3"/>
            <extension module="org.jboss.as.jaxrs"/>
            <extension module="org.jboss.as.jmx"/>
            <extension module="org.jboss.as.jpa"/>
            <extension module="org.jboss.as.logging"/>
            <extension module="org.jboss.as.naming"/>
            <extension module="org.jboss.as.osgi"/>
            <extension module="org.jboss.as.remoting"/>
            <extension module="org.jboss.as.sar"/>
            <extension module="org.jboss.as.security"/>
            <extension module="org.jboss.as.threads"/>
            <extension module="org.jboss.as.transactions"/>
            <extension module="org.jboss.as.web"/>
            <extension module="org.jboss.as.weld"/>
        </extensions>
        <management>
            <security-realms>
                <security-realm name="PropertiesMgmtSecurityRealm">
                    <authentication>
                        <ldap connection="my_ldap" base-dn="ou=users,dc=myDomain,dc=badr,dc=com" username-attribute="uid"/>
                    </authentication>
                </security-realm>
            </security-realms>
            <outbound-connections>
                <ldap name="my_ldap" url="ldap://10.99.99.90" search-dn="uid=fero,ou=users,dc=myDomain,dc=badr,dc=com" search-credential="hero"/>
            </outbound-connections>
            <management-interfaces>
                <native-interface interface="management" port="9999"/>
                <http-interface interface="management" port="9990" security-realm="PropertiesMgmtSecurityRealm"/>
            </management-interfaces>
        </management>
        <profile>
            <subsystem xmlns="urn:jboss:domain:logging:1.1">
                <console-handler name="CONSOLE" autoflush="true">
                    <level name="INFO"/>
                    <formatter>
                        <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                    </formatter>
                </console-handler>
                <periodic-rotating-file-handler name="FILE" autoflush="true">
                    <level name="INFO"/>
                    <formatter>
                        <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                    </formatter>
                    <file relative-to="jboss.server.log.dir" path="server.log"/>
                    <suffix value=".yyyy-MM-dd"/>
                    <append value="true"/>
                </periodic-rotating-file-handler>
                <logger category="com.arjuna">
                    <level name="WARN"/>
                </logger>
                <logger category="org.apache.tomcat.util.modeler">
                    <level name="WARN"/>
                </logger>
                <logger category="sun.rmi">
                    <level name="WARN"/>
                </logger>
                <root-logger>
                    <level name="INFO"/>
                    <handlers>
                        <handler name="CONSOLE"/>
                        <handler name="FILE"/>
                    </handlers>
                </root-logger>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:datasources:1.0">
                <datasources>
                    <datasource jndi-name="java:/DefaultDS" pool-name="OracleDS" enabled="true" jta="true" use-java-context="true" use-ccm="true">
                    <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="H2DS" enabled="true" jta="true" use-java-context="true" use-ccm="true">
                        <connection-url>
                            jdbc:h2:mem:test;DB_CLOSE_DELAY=-1
                        </connection-url>
                        <driver>
                            h2
                        </driver>
                        <pool>
                            <prefill>
                                false
                            </prefill>
                            <use-strict-min>
                                false
                            </use-strict-min>
                            <flush-strategy>
                                FailingConnectionOnly
                            </flush-strategy>
                        </pool>
                        <security>
                            <user-name>
                                sa
                            </user-name>
                            <password>
                                sa
                            </password>
                        </security>
                    </datasource>
                    <drivers>
                        <driver name="ojdbc6-11.2.0.1.0" module="">
                            <xa-datasource-class>
                                oracle.jdbc.xa.client.OracleXADataSource
                            </xa-datasource-class>
                        </driver>
                        <driver name="h2" module="com.h2database.h2">
                            <xa-datasource-class>
                                org.h2.jdbcx.JdbcDataSource
                            </xa-datasource-class>
                        </driver>
                    </drivers>
                </datasources>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.0">
                <deployment-scanner name="default" path="deployments" scan-enabled="true" scan-interval="5000" relative-to="jboss.server.base.dir" deployment-timeout="60"/>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:ee:1.0">
                <global-modules>
                    <module name="sun.jdk" slot="main"/>
                </global-modules>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:ejb3:1.1" lite="true">
                <session-bean>
                    <stateless>
                        <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>
                    </stateless>
                </session-bean>
                <pools>
                    <bean-instance-pools>
                        <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                    </bean-instance-pools>
                </pools>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:infinispan:1.0" default-cache-container="hibernate">
                <cache-container name="hibernate" default-cache="local-query">
                    <local-cache name="entity">
                        <eviction strategy="LRU" max-entries="10000"/>
                        <expiration max-idle="100000"/>
                    </local-cache>
                    <local-cache name="local-query">
                        <eviction strategy="LRU" max-entries="10000"/>
                        <expiration max-idle="100000"/>
                    </local-cache>
                    <local-cache name="timestamps">
                        <eviction strategy="NONE"/>
                    </local-cache>
                </cache-container>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>
            <subsystem xmlns="urn:jboss:domain:jca:1.0">
                <archive-validation enabled="false"/>
                <bean-validation enabled="false"/>
                <default-workmanager>
                    <short-running-threads blocking="true" allow-core-timeout="false">
                        <core-threads count="10" per-cpu="20"/>
                        <queue-length count="10" per-cpu="20"/>
                        <max-threads count="10" per-cpu="20"/>
                        <keepalive-time time="10" unit="SECONDS"/>
                    </short-running-threads>
                    <long-running-threads blocking="true" allow-core-timeout="false">
                        <core-threads count="10" per-cpu="20"/>
                        <queue-length count="10" per-cpu="20"/>
                        <max-threads count="10" per-cpu="20"/>
                        <keepalive-time time="10" unit="SECONDS"/>
                    </long-running-threads>
                </default-workmanager>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:jmx:1.0">
                <jmx-connector server-binding="jmx-connector-server" registry-binding="jmx-connector-registry"/>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:jpa:1.0">
                <jpa default-datasource=""/>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:naming:1.0"/>
            <subsystem xmlns="urn:jboss:domain:osgi:1.0" activation="lazy">
                <configuration pid="org.apache.felix.webconsole.internal.servlet.OsgiManager">
                    <property name="manager.root">
                        jboss-osgi
                    </property>
                </configuration>
                <properties>
                    <property name="org.jboss.osgi.system.modules">
                        org.apache.commons.logging,                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           org.jboss.as.osgi,
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    org.slf4j,
                    </property>
                    <property name="org.osgi.framework.startlevel.beginning">
                        1
                    </property>
                    <property name="org.osgi.framework.system.packages.extra">
                        org.apache.commons.logging;version=1.1.1,
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 org.slf4j;version=1.5.10,
                    </property>
                </properties>
                <modules>
                    <module identifier="javaee.api"/>
                    <module identifier="org.jboss.logging"/>
                    <module identifier="org.apache.aries.util"/>
                    <module identifier="org.jboss.osgi.webconsole"/>
                    <module identifier="org.osgi.compendium"/>
                    <module identifier="org.apache.felix.log" startlevel="1"/>
                    <module identifier="org.jboss.osgi.logging" startlevel="1"/>
                    <module identifier="org.apache.felix.configadmin" startlevel="1"/>
                    <module identifier="org.jboss.as.osgi.configadmin" startlevel="1"/>
                    <module identifier="org.apache.aries.jmx" startlevel="2"/>
                    <module identifier="org.apache.felix.eventadmin" startlevel="2"/>
                    <module identifier="org.apache.felix.metatype" startlevel="2"/>
                    <module identifier="org.apache.felix.scr" startlevel="2"/>
                    <module identifier="org.apache.felix.webconsole" startlevel="2"/>
                    <module identifier="org.jboss.osgi.jmx" startlevel="2"/>
                    <module identifier="org.jboss.osgi.http" startlevel="2"/>
                    <module identifier="org.jboss.osgi.blueprint" startlevel="3"/>
                    <module identifier="org.jboss.osgi.webapp" startlevel="3"/>
                    <module identifier="org.jboss.osgi.xerces" startlevel="3"/>
                </modules>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:remoting:1.0"/>
            <subsystem xmlns="urn:jboss:domain:resource-adapters:1.0"/>
            <subsystem xmlns="urn:jboss:domain:sar:1.0"/>
            <subsystem xmlns="urn:jboss:domain:security:1.0">
                <security-domains>
                    <security-domain name="my_ldap_domain" cache-type="default">
                        <authentication>
                            <login-module code="org.jboss.security.auth.spi.LdapLoginModule" flag="required">
                                <module-option name="java.naming.factory.initial" value="com.sun.jndi.ldap.LdapCtxFactory"/>
                                <module-option name="java.naming.provider.url" value="ldap://10.99.99.90"/>
                                <module-option name="java.naming.security.authentication" value="simple"/>
                                <module-option name="principalDNPrefix" value="uid="/>
                                <module-option name="principalDNSuffix" value=",ou=users,dc=myDomain,dc=badr,dc=com"/>
                                <module-option name="searchTimeLimit" value="5000"/>
                                <module-option name="searchScope" value="ONELEVEL_SCOPE"/>
                            </login-module>
                        </authentication>
                    </security-domain>
                </security-domains>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:threads:1.0"/>
            <subsystem xmlns="urn:jboss:domain:transactions:1.0">
                <core-environment>
                    <process-id>
                        <uuid/>
                    </process-id>
                </core-environment>
                <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
                <coordinator-environment default-timeout="300"/>
                <object-store/>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:web:1.0" default-virtual-server="default-host">
                <connector name="http" protocol="HTTP/1.1" socket-binding="http" scheme="http"/>
                <virtual-server name="default-host" enable-welcome-root="true">
                    <alias name="localhost"/>
                    <alias name="example.com"/>
                </virtual-server>
            </subsystem>
            <subsystem xmlns="urn:jboss:domain:weld:1.0"/>
        </profile>
        <interfaces>
            <interface name="management">
                <inet-address value="10.99.99.90"/>
            </interface>
            <interface name="public">
                <inet-address value="10.99.99.90"/>
            </interface>
        </interfaces>
        <socket-binding-group name="standard-sockets" default-interface="public">
            <socket-binding name="http" port="8080"/>
            <socket-binding name="https" port="8443"/>
            <socket-binding name="jmx-connector-registry" port="1090"/>
            <socket-binding name="jmx-connector-server" port="1091"/>
            <socket-binding name="jndi" port="1099"/>
            <socket-binding name="osgi-http" port="8090"/>
            <socket-binding name="remoting" port="4447"/>
            <socket-binding name="txn-recovery-environment" port="4712"/>
            <socket-binding name="txn-status-manager" port="4713"/>
        </socket-binding-group>
    </server>
    
    

     

    Arquilian.xml (first test from getting started)

     

    <?xml version="1.0" encoding="UTF-8"?>
    <arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
              xsi:schemaLocation="http://jboss.org/schema/arquillian http://jboss.org/schema/arquillian/arquillian-1.0.xsd">
    
              <engine>
                        <property name="deploymentExportPath">target/</property>
              </engine>
    
              <defaultProtocol type="Servlet 3.0" />
    
    </arquillian>
    
    

     

    Arquilian.xml following https://docs.jboss.org/author/display/ARQ/JBoss+AS+7.0+-+Remote

     

     

    <?xml version="1.0" encoding="UTF-8"?>
    <arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
              xsi:schemaLocation="http://jboss.org/schema/arquillian http://jboss.org/schema/arquillian/arquillian-1.0.xsd">
    
              <container qualifier="jboss7" default="true">
                        <protocol type="jmx-as7">
                                  <property name="executionType">REMOTE</property>
                                  <property name="managementAddress">10.99.99.90</property>
                                  <property name="managementPort">9999</property>
                        </protocol>
              </container>
    
    </arquillian>
    
    

    In that configuration i juste guess it and i'm not sure it should be configured like that

  • 5. Re: Configure Arquillian with Custom Jboss AS7
    Aslak Knutsen Master

    managementAddress and managementPort is a Container configuration, not a Protocol configuration. Try this:

     

     

      <container qualifier="jboss7" default="true">
        <configuration>
          <property name="managementAddress">10.99.99.90</property>
          <property name="managementPort">9999</property>
        </configuration>
      </container>
    

     

    In 7.0.1 you no longer have to define the executionType=REMOTE under protocol.

  • 6. Re: Configure Arquillian with Custom Jboss AS7
    Aslak Knutsen Master

    And with JSFUnit, you still want the defaultProtocol set to Servlet 3.0 + a dependency on org.jboss.arquillian.protocol:arquillian-protocol-servlet

     

    <defaultProtocol type="Servlet 3.0" />

  • 7. Re: Configure Arquillian with Custom Jboss AS7
    badr elhouari Novice

    Thanks Aslak,

     

    The configuration works for me and arquillian was able to access my jboss with that IP adress ( i think it would be better to add a page describing custom configuration with arquillian ;-)

     

    Now i've the error : java.lang.Exception: {"Services with missing/unavailable dependencies" => ["jboss.web.deployment.default-host./test.realm missing [ jboss.security.security-domain.other ]"]}

     

    even if i add a jboss-web.xml under my WEB-INF with the following :

     

    <?xml version="1.0" encoding="UTF-8"?>

    <jboss-web>

         <security-domain>my_ldap_domain</security-domain>

    </jboss-web>

     

    Do you have anny idea about that

  • 8. Re: Configure Arquillian with Custom Jboss AS7
    badr elhouari Novice

    I forgot to add jboss-web.xml to my createDeployment() methode !

     

    Now everything works fine !

     

    Thanks a lot

  • 9. Re: Configure Arquillian with Custom Jboss AS7
    Aslak Knutsen Master

    How are you adding it ?

     

    I assume this is a deployment exception right ?

  • 10. Re: Configure Arquillian with Custom Jboss AS7
    badr elhouari Novice

    Yes, i've updated the post beffor!

     

    i've missed to add .addAsWebInfResource(new File("src/main/webapp/WEB-INF/jboss-web.xml"), "jboss-web.xml"); in my deployement

     

    Thanks a lot

  • 11. Re: Configure Arquillian with Custom Jboss AS7
    Aslak Knutsen Master

    aa, excellent!

  • 12. Re: Configure Arquillian with Custom Jboss AS7
    hantsy bai Master

    I tried the getting started example and got the following exception on JBoss7.0.2Final

     

     

    -------------------------------------------------------------------------------
    Test set: org.jboss.jsfunit.example.hellojsf.HelloJSFTest
    -------------------------------------------------------------------------------
    Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 19.718 sec <<< FAILURE!
    org.jboss.jsfunit.example.hellojsf.HelloJSFTest  Time elapsed: 0 sec  <<< ERROR!
    java.lang.IllegalArgumentException
        at java.net.URI.create(URI.java:841)
        at org.jboss.as.arquillian.container.ManagementClient.getBinding(ManagementClient.java:181)
        at org.jboss.as.arquillian.container.ManagementClient.extractSubSystemURI(ManagementClient.java:148)
        at org.jboss.as.arquillian.container.ManagementClient.getSubSystemURI(ManagementClient.java:90)
        at org.jboss.as.arquillian.container.ManagementClient.getDeploymentMetaData(ManagementClient.java:96)
        at org.jboss.as.arquillian.container.CommonDeployableContainer.deploy(CommonDeployableContainer.java:98)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController$3.call(ContainerDeployController.java:148)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController$3.call(ContainerDeployController.java:115)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController.executeOperation(ContainerDeployController.java:258)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController.deploy(ContainerDeployController.java:114)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.invokeObservers(EventContextImpl.java:99)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:81)
        at org.jboss.arquillian.container.impl.client.ContainerDeploymentContextHandler.createDeploymentContext(ContainerDeploymentContextHandler.java:78)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:88)
        at org.jboss.arquillian.container.impl.client.ContainerDeploymentContextHandler.createContainerContext(ContainerDeploymentContextHandler.java:57)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:88)
        at org.jboss.arquillian.container.impl.client.container.DeploymentExceptionHandler.verifyExpectedExceptionDuringDeploy(DeploymentExceptionHandler.java:50)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:88)
        at org.jboss.arquillian.core.impl.ManagerImpl.fire(ManagerImpl.java:134)
        at org.jboss.arquillian.core.impl.ManagerImpl.fire(ManagerImpl.java:114)
        at org.jboss.arquillian.core.impl.EventImpl.fire(EventImpl.java:67)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController$1.perform(ContainerDeployController.java:86)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController$1.perform(ContainerDeployController.java:79)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController.forEachDeployment(ContainerDeployController.java:250)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController.forEachManagedDeployment(ContainerDeployController.java:226)
        at org.jboss.arquillian.container.impl.client.container.ContainerDeployController.deployManaged(ContainerDeployController.java:78)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.invokeObservers(EventContextImpl.java:99)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:81)
        at org.jboss.arquillian.core.impl.ManagerImpl.fire(ManagerImpl.java:134)
        at org.jboss.arquillian.core.impl.ManagerImpl.fire(ManagerImpl.java:114)
        at org.jboss.arquillian.core.impl.EventImpl.fire(EventImpl.java:67)
        at org.jboss.arquillian.container.test.impl.client.ContainerEventController.execute(ContainerEventController.java:97)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.invokeObservers(EventContextImpl.java:99)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:81)
        at org.jboss.arquillian.test.impl.TestContextHandler.createClassContext(TestContextHandler.java:68)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:88)
        at org.jboss.arquillian.test.impl.TestContextHandler.createSuiteContext(TestContextHandler.java:54)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.jboss.arquillian.core.impl.ObserverImpl.invoke(ObserverImpl.java:90)
        at org.jboss.arquillian.core.impl.EventContextImpl.proceed(EventContextImpl.java:88)
        at org.jboss.arquillian.core.impl.ManagerImpl.fire(ManagerImpl.java:134)
        at org.jboss.arquillian.core.impl.ManagerImpl.fire(ManagerImpl.java:114)
        at org.jboss.arquillian.test.impl.EventTestRunnerAdaptor.beforeClass(EventTestRunnerAdaptor.java:80)
        at org.jboss.arquillian.junit.Arquillian$2.evaluate(Arquillian.java:158)
        at org.jboss.arquillian.junit.Arquillian.multiExecute(Arquillian.java:290)
        at org.jboss.arquillian.junit.Arquillian.access$100(Arquillian.java:45)
        at org.jboss.arquillian.junit.Arquillian$3.evaluate(Arquillian.java:175)
        at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
        at org.jboss.arquillian.junit.Arquillian.run(Arquillian.java:123)
        at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:35)
        at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:115)
        at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:97)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.maven.surefire.booter.ProviderFactory$ClassLoaderProxy.invoke(ProviderFactory.java:103)
        at $Proxy0.invoke(Unknown Source)
        at org.apache.maven.surefire.booter.SurefireStarter.invokeProvider(SurefireStarter.java:150)
        at org.apache.maven.surefire.booter.SurefireStarter.runSuitesInProcess(SurefireStarter.java:91)
        at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:69)
    Caused by: java.net.URISyntaxException: Illegal character in authority at index 7: http://${jboss.bind.address:127.0.0.1}:8080
        at java.net.URI$Parser.fail(URI.java:2810)
        at java.net.URI$Parser.parseAuthority(URI.java:3148)
        at java.net.URI$Parser.parseHierarchical(URI.java:3059)
        at java.net.URI$Parser.parse(URI.java:3015)
        at java.net.URI.<init>(URI.java:577)
        at java.net.URI.create(URI.java:839)
        ... 98 more
    
    
  • 13. Re: Configure Arquillian with Custom Jboss AS7
    rajivtmathew Newbie

    It would be helpful to have an arquillian dependency tree for JBoss7, for reference.

     

     

    I'm running into some dependency issues when running arquillian against JBoss 7.1.1.Final. Project is built using gradle. Here are my dependencies:

     


    arquillian = [group: 'org.jboss.arquillian', name: 'arquillian-parent', version: '1.0.0.CR5']

    arquilliancore = [group: 'org.jboss.arquillian.core', name: 'arquillian-core-api', version: '1.0.0.CR5']

    arquilliancontainertest = [group: 'org.jboss.arquillian.container', name: 'arquillian-container-test-impl-base', version: '1.0.0.CR5']

    arquilliancontainerremote = [group: 'org.jboss.as', name: 'jboss-as-arquillian-container-remote', version: '7.1.1.Final']

    arquilliantest = [group: 'org.jboss.arquillian.test', name: 'arquillian-test-impl-base', version: '1.0.0.CR6']

    arquilliantestapi = [group: 'org.jboss.arquillian.container', name: 'arquillian-container-test-api', version: '1.0.0.CR5']

    arquillianspi = [group: 'org.jboss.arquillian.container', name: 'arquillian-container-spi', version: '1.0.0.CR5']

    arquillianjunit = [group: 'org.jboss.arquillian.junit', name: 'arquillian-junit-core', version: '1.0.0.CR5']

     

     

    My arquillian.xml file looks like:

     

     

    <?xml version="1.0" encoding="UTF-8"?>

    <arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                xmlns="http://jboss.org/schema/arquillian"

                xsi:schemaLocation="http://jboss.org/schema/arquillian http://jboss.org/schema/arquillian/arquillian_1_0.xsd">

     

        <container qualifier="jboss7" default="true">

            <protocol type="jmx-as7">

                <property name="executionType">REMOTE</property>

            </protocol>

        </container>

    </arquillian>