1 Reply Latest reply: Jul 17, 2011 12:55 AM by jaikiran pai RSS

standalone.xml altered with each start

Brian Hiles Newbie

On my Windows machine, standalone.xml gets altered with each start of the server. It seems the section around the osgi subsystem keeps getting kicked out by a tab or two with each start.

 

These are the two sections. All the rest of the file seems to be staying stable. Is this a bug beyond the three systems I've tested on? Didn't see anything logged for it.

 

<subsystem xmlns="urn:jboss:domain:osgi:1.0" activation="lazy">
            <configuration pid="org.apache.felix.webconsole.internal.servlet.OsgiManager">
                <property name="manager.root">
                    jboss-osgi
                </property>
            </configuration>
            <properties>
                <property name="org.jboss.osgi.system.modules">
                    org.apache.commons.logging,
                                                                                                                                                                                org.apache.log4j,
                                                                                                                                                                                org.jboss.as.osgi,
                                                                                                                                                                                org.slf4j,
                </property>
                <property name="org.osgi.framework.system.packages.extra">
                    org.apache.commons.logging;version=1.1.1,
                                                                                                                                                                                org.apache.log4j;version=1.2,
                                                                                                                                                                                org.jboss.as.osgi.service;version=7.0,
                                                                                                                                                                                org.jboss.osgi.deployment.interceptor;version=1.0,
                                                                                                                                                                                org.jboss.osgi.spi.capability;version=1.0,
                                                                                                                                                                                org.jboss.osgi.spi.util;version=1.0,
                                                                                                                                                                                org.jboss.osgi.testing;version=1.0,
                                                                                                                                                                                org.jboss.osgi.vfs;version=1.0,
                                                                                                                                                                                org.slf4j;version=1.5.10,
                </property>
                <property name="org.osgi.framework.startlevel.beginning">
                    1
                </property>
            </properties>