What version of Surefire should I use to run my Arquillian tests in a Maven build?

Sometimes, using the right version of Surefire in your Maven project is important. Version 2.9 of Surefire contains a bug fix for SUREFIRE-743, which prevents a container from cleaning up after an Arquillian test run; see ARQ-282. This could mean that a managed container used in your test run will not be shutdown unless you use Surefire 2.9 or higher.

 

To configure your project to use Surefire 2.9 or above, incorporate the following snippet in your project POM:

<!-- snip -->
<build>
    <plugins>
        <plugin>
            <artifactId>maven-surefire-plugin</artifactId>
            <version>2.9</version>
         </plugin>
    </plugins>
</build>