The following versions of JGroups are supported on a community basis (see what this means further down):

    • The latest stable release (3.6.x at the time of writing this)
    • Git master


    On a commercial basis, we support the following versions of JGroups if run inside the Enterprise Application Platform (EAP):

    • EAP 4: 2.4.x
    • EAP 5: 2.6.x
    • EAP 6: 3.2.12.Final (EAP 6.3.0)
    • EAP 7: 3.4.x (or 3.5, not decided yet)


    The other versions like 2.5.x, [2.7.x - 2.12.x], [3.1-3.4] are not supported !


    For list of supported classes see the documentation "2.11. Supported classes" section.


    Community support

    This is support of the community versions via the JGroups mailing lists on (preferred) or forums (not preferred). Members of the development team and the community try to answer questions related to JGroups. This support has no guaranteed response times and questions may not get answered at all. If you want guaranteed response times, I recommend a service contract (support, consulting, training etc). For details, go to


    I usually use the following criteria to answer questions:


    Will answer:

    • Architectural questions, best practices
    • Someone found a bug. A plus is if the bug can be reproduced. Even better, if a unit test reproduces the bug !
    • A new use case for JGroups
    • Currently: large scale questions / issues


    Will not answer:

    • Answer is in the documentation ( or wiki
    • JBossCache questions
    • Questions with 40MB logs attached (happens on a regular basis ! :-))
    • Too little information, e.g. no version, how to reproduce. "It doesn't work !" questions...
    • If you write an email in all capital letters (with URGENT !!! added), it goes right into my spam folder... :-)
    • Questions on old versions, see the suppported versions above.