RichFaces 3.x, 4.x Dependencies

Community

RichFaces 4.0.x

Client-Side

core-impl

  • jQuery v1.7.1

ui

  • jquery-atmosphere v0.8.4
  • jquery-mousewheel v3.0.4
  • jquery.effects.core v1.8.5
  • jquery.effects.highlight v1.8.5
  • jQuerySpinBtn v rf1.3a (rewritten)
  • jquery-dnd v 1.8.6
  • jquery-ui-core v1.8.6
  • jquery.component

Server-Side

"compile" and "provided" dependencies.

core-api

com.google.guava:guava:jar:r08:compile

javax.el:el-api:jar:1.0:provided

javax.servlet:servlet-api:jar:2.5:provided

com.sun.faces:jsf-api:jar:2.0.4-b09:provided

core-impl

org.richfaces.core:richfaces-core-api:jar:4.0.1-SNAPSHOT:compile

net.sourceforge.cssparser:cssparser:jar:0.9.5:compile

org.w3c.css:sac:jar:1.3:compile

com.google.guava:guava:jar:r08:compile

javax.el:el-api:jar:1.0:provided

javax.servlet:servlet-api:jar:2.5:provided

javax.servlet.jsp:jsp-api:jar:2.1:provided

javax.servlet:jstl:jar:1.2:provided

org.jboss.cache:jbosscache-core:jar:3.2.5.GA:compile

jgroups:jgroups:jar:2.6.13.GA:compile

org.jboss.javaee:jboss-transaction-api:jar:1.0.1.GA:compile

commons-logging:commons-logging:jar:1.1.1:compile

org.jboss:jboss-common-core:jar:2.2.14.GA:compile

org.jboss.logging:jboss-logging-spi:jar:2.0.5.GA:compile

net.sf.ehcache:ehcache:jar:1.6.0:compile

opensymphony:oscache:jar:2.3:compile

org.atmosphere:atmosphere-runtime:jar:0.6.5:compile

org.atmosphere:atmosphere-compat-jbossweb:jar:0.6.5:compile

org.atmosphere:atmosphere-compat-weblogic:jar:0.6.5:compile

org.atmosphere:atmosphere-compat-tomcat:jar:0.6.5:compile

javax.jms:jms:jar:1.1:compile

com.sun.faces:jsf-api:jar:2.0.4-b09:provided

components-api

com.google.guava:guava:jar:r08:compile

javax.servlet:servlet-api:jar:2.5:provided

javax.servlet.jsp:jsp-api:jar:2.1:provided

javax.el:el-api:jar:1.0:provided

javax.servlet:jstl:jar:1.2:provided

com.sun.faces:jsf-api:jar:2.0.4-b09:provided

components-ui

com.google.guava:guava:jar:r08:compile

javax.servlet:servlet-api:jar:2.5:provided

javax.servlet.jsp:jsp-api:jar:2.1:provided

javax.el:el-api:jar:1.0:provided

javax.servlet:jstl:jar:1.2:provided

com.sun.faces:jsf-api:jar:2.0.4-b09:provided

RichFaces 3.3.x

Latest community release 3.3.3.Final.

Client-Side

framework-impl

  • prototype.js 1.6.0.3
  • jQuery 1.3.2
    • jquery.jcarousel.js (why there? not sure that used, maybe just outdated)
  • scriptaculous.js 1.8.2
    • builder.js,effects.js,dragdrop.js,controls.js,slider.js,sound.js
  • Sarissa 0.9.9.3

richfaces-ui

Server-side

"compile" and "provided" dependencies for framework and ui modules:

api

commons-collections:commons-collections:jar:3.2:compile

commons-beanutils:commons-beanutils:jar:1.8.0:compile

com.sun.facelets:jsf-facelets:jar:1.1.15.B1:compile

commons-logging:commons-logging:jar:1.0.4:compile

javax.faces:jsf-api:jar:1.2_12:provided

javax.el:el-api:jar:2.2:provided

javax.servlet:servlet-api:jar:2.5:provided

javax.servlet.jsp:jsp-api:jar:2.1:provided

javax.servlet:jstl:jar:1.2:provided

javax.annotation:jsr250-api:jar:1.0:provided

impl

opensymphony:oscache:jar:2.3:compile

nekohtml:nekohtml:jar:1.9.6:compile

xerces:xercesImpl:jar:2.9.1:compile

commons-digester:commons-digester:jar:1.8.1:compile

commons-beanutils:commons-beanutils:jar:1.8.0:compile

commons-collections:commons-collections:jar:3.2:compile

com.sun.facelets:jsf-facelets:jar:1.1.15.B1:compile

commons-logging:commons-logging:jar:1.0.4:compile

javax.faces:jsf-api:jar:1.2_12:provided

javax.servlet:servlet-api:jar:2.5:provided

javax.servlet.jsp:jsp-api:jar:2.1:provided

javax.servlet:jstl:jar:1.2:provided

javax.annotation:jsr250-api:jar:1.0:provided

ui

commons-collections:commons-collections:jar:3.2:compile

commons-beanutils:commons-beanutils:jar:1.8.0:compile

opensymphony:oscache:jar:2.3:compile

nekohtml:nekohtml:jar:1.9.6:compile

xerces:xercesImpl:jar:2.9.1:compile

commons-digester:commons-digester:jar:1.8.1:compile

com.sun.facelets:jsf-facelets:jar:1.1.15.B1:compile

javax.el:el-api:jar:2.2:provided

commons-logging:commons-logging:jar:1.0.4:provided (scope not updated to compile)

javax.servlet:servlet-api:jar:2.5:provided

javax.servlet.jsp:jsp-api:jar:2.1:provided

javax.servlet:jstl:jar:1.2:provided

javax.faces:jsf-api:jar:1.2_12:provided

javax.faces:jsf-impl:jar:1.2_12:provided

 

Note: to check full dependencies lists including test scoped dependencies use maven dependency plugin.