Problem Deploying ear file

Hello,

 

Im using JBoss AS 5.1.0 under Solaris 10 SPARC. I make a copy of default configuration and I'm trying to hot deploy an .ear file but i get the follow error:

 

        at java.lang.Thread.run(Thread.java:662)

Caused by: java.lang.IllegalStateException: Expected either '.jar' or '.jar/' at the end of CreditLetters.war

        at org.jboss.ejb3.deployers.Ejb3ClientDeployer.getDeploymentJndiName(Ejb3ClientDeployer.java:214)

        at org.jboss.ejb3.deployers.Ejb3ClientDeployer.deploy(Ejb3ClientDeployer.java:106)

        at org.jboss.ejb3.deployers.Ejb3ClientDeployer.deploy(Ejb3ClientDeployer.java:61)

        at org.jboss.deployers.vfs.spi.deployer.AbstractSimpleVFSRealDeployer.deploy(AbstractSimpleVFSRealDeployer.java:56)

        at org.jboss.deployers.spi.deployer.helpers.AbstractSimpleRealDeployer.internalDeploy(AbstractSimpleRealDeployer.java:62)

        at org.jboss.deployers.spi.deployer.helpers.AbstractRealDeployer.deploy(AbstractRealDeployer.java:50)

        at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:171)

        ... 24 more

2011-01-19 16:04:50,285 WARN  [org.jboss.system.server.profileservice.hotdeploy.HDScanner] Failed to process changes

org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

 

*** DEPLOYMENTS IN ERROR: Name -> Error

 

vfszip:/export/home/desarrollo/jboss/deploytest/CreditLetters.war/ -> org.jboss.deployers.spi.DeploymentException: Error during deploy: vfszip:/export/home/desarrollo/jboss/deploytest/CreditLetters.war/

 

 

DEPLOYMENTS IN ERROR:

  Deployment "vfszip:/export/home/desarrollo/jboss/deploytest/CreditLetters.war/" is in error due to the following reason(s): java.lang.IllegalStateException: Expected either '.jar' or '.jar/' at the end of CreditLetters.war

 

        at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:993)

        at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:939)

        at org.jboss.deployers.plugins.main.MainDeployerImpl.checkComplete(MainDeployerImpl.java:873)

        at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.checkComplete(MainDeployerAdapter.java:128)

        at org.jboss.system.server.profileservice.hotdeploy.HDScanner.scan(HDScanner.java:369)

        at org.jboss.system.server.profileservice.hotdeploy.HDScanner.run(HDScanner.java:255)

        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)

        at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)

        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)

        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)

        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:180)

        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:204)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)

        at java.lang.Thread.run(Thread.java:662)

 

The same .ear file was deployed in JBoss AS 4.2.2, I don't know if is an appserver version issue or some type of configuration that i haven't set yet.