JbossRetroMavenPlugin

This plugin allows maven to call JBossRetro to generate jdk1.4 compatible jar files.

 

To use the plugin, add it to the plugins section of your pom similar to this:

      <plugin>
        <groupId>jboss.maven-plugins</groupId>
        <artifactId>jboss-retro-maven-plugin</artifactId>
        <version>0.5</version>
        <executions>
          <execution>
            <goals>
              <goal>retro-compile</goal>
            </goals>
          </execution>
        </executions>
      </plugin>

 

By default the plugin attaches to the process-classes phase.

The goal retro-compile will compile your project artifact for jdk1.4.  The generated artifact will have the same name as your main project artifact, but with the classifier "jdk14".

 

The plugin's functionality is still fairly limited.  If you have features that you would like to request, you can post them to the jboss-build issue tracker here:

http://jira.jboss.com/jira/browse/JBBUILD