JSFUnitSupportedEnvironments

Supported environments for JBossJSFUnit

 

JDK

JBossJSFUnit supports JDK 1.5 and higher.

 

JSF Implementations

  • MyFaces 1.1.x

  • MyFaces 1.2.x

  • MyFaces 2.0.x
  • MyFaces 2.1.x
  • Mojarra 1.1.x (not tested, but it should work)

  • Mojarra 1.2.x

  • Mojarra 2.0.x

  • Mojarra 2.1.x

 

App Servers/Servlet Containers

JBossJSFUnit should work on any servlet container that supports the above JSF implementations.

 

If you are using WebSphere you will need this workaround.

 

JSF Component Libraries

JSFUnit supports all the standard JSF components.  Other component libraries are supported insofar as they work with HtmlUnit.

 

Currently, we are concentrating on the RichFaces library, but others such as Tomahawk are known to mostly work.  Both the JSFUnit team and the HtmlUnit team are very interested in making sure that all popular component libraries are supported with a high degree of confidence.  If you come across a bug while testing with any JSF component, feel free to report it on our forums here.

 

View implementations

JBossJSFUnit works with both JSP and Facelets