JBossVsJavaJDKVersionMatrix

JBoss vs Java JDK Version Matrix

 

Which version of the JDK is required for which versions of JBoss AS?

 

JBoss version series

3.2.x

4.0.x

4.2.x

5.0.x

6.0

compiles with JDK version

1.3/1.4

1.4/5.0

5.0/6.0

5.0/6.0

6.0

runs under JDK version

1.3/1.4/5.0

1.4/5.0

5.0/6.0

5.0/6.06.0

 

Notes:

  • JBoss AS 3.2.6+ and 4.0.1+ are the ONLY versions to be fully functional under JDK 5, due to JMX issues.  See RunJBossWithJ2SDK1.5Beta for more details.

  • JBoss AS 3.2.6 doesn't run with JDK 1.3. This issue is fixed in the JBoss AS 3.2.7.

  • JBoss AS 4.0.0 runs under JDK 1.5, but the jconsole utility will not work with it. You need 4.0.1, 3.2.7 to use jconsole.

  • Compliation using JDK 5 requires use of the -source 1.4 javac argument to avoid errors due to JDK 5 reserved words like enum.

  • JBoss AS 4.0.3+ and JBoss AS 5 source code has been fixed such that it no longer uses the enum reserved word in variable names.

  • The current group of 64 bit JVMs have some stability issues.  Please do extensive testing on the 64 bit JVM before using it in Production. (PeterJ: I think this warning no longer applies.)

  • 64 bit hardware does provide some performance gains for 32 or 64 bit JVMs.

  • Be careful running the JDK1.3 on 64bit version of Linux.  See Linux64andJDK1.3 for details.

  • Since JBoss v4.0.3, compiling the server with JDKv1.4 and JDKv5 produces somewhat different outputs. A JDKv1.4 compilation produces the classic jboss distribution. A JDKv5 compilation includes JDK5 only features, like EJB3.

  • JBoss AS 4.2.x needs an out-of-tree patch to build with JDK 6, see JBossWithJDK6 for details

 

Referenced by: