InstallingJBossWiki

JBoss Wiki - Installation

 

Now JBoss Wiki can be deployed correctly on JBoss Portal 2.6.x and 2.7.x.

 

Be aware JBoss Wiki needs JRE1.5+ to run. It isn't compatible with JRE1.4. Also you'll need JBoss AS 4.0.4 with running JBoss Portal 2.2.1+ and EJB3 RC8+.

Important is to make it use "all" configuration. We've tried using default, with EJB3 from installer but couldn't make it work.

 

First go to the Downloads section and download version that suits you the most.

If you have problems to deploy it on a preview version of portal or different AS version you can try to download JBoss Wiki Beta versions here.

 

Precompiled version

If you choose binary version be aware it is rather made to check how it works. It uses /tmp as the wiki filestructure and attachment path. To change it you'll have to decompress the war, change appropriate properties and the compress it again.

 

Source version

Check out the source tree from: http://anonsvn.jboss.org/repos/portletswap/contrib/wikiPortlet/tags/1.0/

This is the version if you are planning to actually use JBoss Wiki.

 

You will need Apache Maven 2 to compile it.

 

Then you must follow the process below: