How do I specify the Selenium version in Arquillian Drone?

Specifiying Drone dependencies on Selenium

 

All the Selenium dependencies are specified in Arquillian Drone BOM file. In your project you should include following snippet:

 

<!-- clip -->
<dependencyManagement>
    <dependencies>
        ...    
        <dependency>
            <groupId>org.jboss.arquillian.extension</groupId>
            <artifactId>arquillian-drone-bom</artifactId>
            <version>1.1.1.Final</version>
            <type>pom</type>
            <scope>import</scope>
        </dependency>
        ...
    </dependencies>
</dependencyManagement>
<!-- clip -->

 

This files contains Drone's Selenium dependency version, so you can be sure you are using Drone + Selenium combination that passed integration testing. You can always check which version is that in Arquillian Documenation at https://docs.jboss.org/author/display/ARQ/Drone.

 

Overriding Drone dependencies on Selenium

It might happen that you want to override the versions by yourself, for example to try it with very new Selenium which contains support for your brand new browser. In that case, you should override the dependencyManagement section and include desired versions before the arquillian-drone-bom dependency. Maven will pick up your versions instead of the ones in the arquillian-drone-bom file:

 

<!-- clip -->

<properties>

     <version.selenium>2.33.0</version.selenium>

</properties>


<dependencyManagement>
    <dependencies>
        ...

            <dependency>
                <groupId>org.jboss.arquillian.selenium</groupId>
                <artifactId>selenium-bom</artifactId>
                <version>${version.selenium}</version>
                <type>pom</type>
                <scope>import</scope>
            </dependency> 
                   ...
    </dependencies>
</dependencyManagement>
<!-- clip -->

 

You can always check latest Selenium BOM version available on Maven Central by following this link:

 

http://search.maven.org/#search%7Cga%7C1%7Cselenium-bom

 

If you want to use Drone with completely different Selenium, e.g. to use pre-Selenium 2 packages for DefaultSelenium browser only, we recommend you to build a <dependencyManagement> section by yourself, copying Drone related dependencies from Arquillian Drone BOM file.