How do I install the TestNG 5.11 Eclipse plugin?

The Arquillian documentation (as of version 1.0.0.Alpha2) contains the following note about the Eclipse TestNG plugin:

 

You must use the 5.11 version of the TestNG Eclipse plugin, which can be downloaded from testng.org. The TestNG update site will give you version 5.12 which is not compatible with any released version of TestNG core.

 

You can install the TestNG 5.11 Eclipse plugin with the version-specific update site:

 

http://beust.com/eclipse-5.11.0.28

 

If you'd rather not mess with the update sites, there is a way to install the plugin manually, which also makes it easier to upgrade IMHO. Just extract the plugin distribution into the Eclipse dropins folder.

 

There are two versions of the TestNG 5.11 Eclipse plugin on the testng.org site:

 

 

Extract one of those and put it in your Eclipse dropins directory and see if it works out.

 

The structure of the dropins directory should look like:

 

$ECLIPSE_INSTALL_DIR/
   dropins/
      testng-eclipse-5.11/
         eclipse/
            plugins/
               org.testng.eclipse_5.11.0.28.jar

 

The preferred version of the plugin has also been attached to this entry.