event attributes naming convention

1) attributes pairs for cancelable events and events fired after some operation

 

in 3.3.x we had two types of names:

modal panel - onshow and onbeforeshow

calendar - ondateselect and ondateselected

 

So some components used past time for name of the event which fired in the result of some operation/user activity and some used "before" word for events which are cancelable instead.

 

Now we should unify the approach for all the components. So the proposal is to use "before" word for all the cancelable events (fired before some operation).

This should be considered during all the compoonents migration.

 

examples:

onbeforeswitch/onswitch for collapsible panel.

onbeforeitemchange/onitemchange - switchable panels.

 

2) Note about camel case for event attributes.


event attributes should not use camel case as it was for tables in 3.3.x (onRowClick) in order to be consistent with all standard components.