8 Replies Latest reply: Dec 15, 2007 3:44 PM by Ales Justin RSS

Running JBoss with Java 6 (JDK 6)

Rene Felder Newbie

Is it possible to run JBoss with Java 6? In the documentation I only found a reference where JDK 1.4 and Java 5 is reccomended:
JBoss 4 requires either a Java 1.4 or Java 5

In the next sentence the documentation says:
The choice of JVMs is yours otherwise, but we do recommend considering the Java 5 JVM where possible to take advantage of the latest JVM performance improvements and monitoring capabilities. No matter what JVM is chosen, you should generally prefer the latest stable versions.

So can I use Java 6 with JBoss 4.x that is the latest stable version for Java? If not can I use Java 6 with JBoss 5.x?

Thx Rene