1 Reply Latest reply: Feb 21, 2013 11:08 PM by Mike Brock RSS

Can anyone compile in strict mode?

Michael Hirsch Newbie

Trying to figure out why I can't use Errai 2.2.0, I decided to try compiling in strict mode.  So I added "-strict" to my compile command and I get this error.

 

   Validating units:

      [ERROR] Errors in 'jar:file:/home/mhirsch/Workspace/jaws-trunk/product/console/lib/errai-2.2.0/deps/lib/gwt-user-2.4.0.jar!/com/google/gwt/validation/client/BaseGwtConfiguration.java'

         [ERROR] Line 54: The constructor GwtConfigurationState() is undefined

   [ERROR] Aborting compile due to errors in some input files

 

Has anyone else seen this?

 

Note that I'm using gwt 2.5.0 and errai includes gwt-user-2.4.0.  I don't know if that is significant.

 

Thanks,

 

Michael