4 Replies Latest reply: Aug 10, 2012 2:23 AM by Kris De Schutter RSS

Queue is filling up; consumers receive nothing ?

Kris De Schutter Newbie

Hello all,

 

The problem I have, in brief, is the following: when trying to consume messages from one of our queues the consumer don't receive any messages. Even though there are messages in the queue (over 1.5 million as I'm writing this). Other queues and consumers are not impacted. I'm hoping you can help me figure out what's going wrong...

 

The details:

* We're running HornetQ 2.2.5.Final in an active/passive failover setup. No failover has occured. We're not close to going out of memory.

* HornetQ is running standalone; that is it's not running inside JBoss or any other application server.

* The queues are set up to be FIFO, with a single consumer on each queue. The consumers are running on a separate JBoss application.

* The queues are set up to use paging. The 'offending' queue is still being writ to, and has already over 1GB of page file data.

* Of the offending queue there are five others with the exact same setup and the exact same type of consumer (not the same instance) which work perfectly.

* The offending queue is known to report a bad message count. A while ago we noticed it was consistently reporting 449 messages while there were in fact none. Other than reporting an incorrect number everything was running fine.

* I set up a small test class which tries to connect to the queue and read just a single message. It successfully connects. Whether reading a message with receiveImmediate() or just receive(TIMEOUT), I still only get null... I tried doing this both through the JMS API and the Core API; no difference.

 

I don't really know where to go from here. So any tips would be greatly appreciated.

 

Thanks in advance!

 

Message was edited by: Kris De Schutter I originally posted this question saying that the consumers were blocked; that was not quite correct.