1 Reply Latest reply: Jul 4, 2012 11:43 AM by Bartosz Majsak RSS

Arquillian dependencies for seam solder 3.1.0 Final and JBoss AS 7.0.1 Final

Ana B Newbie

Hello,

 

We are trying to use Arquillian in our project. I am struggling to figure out what I need to include in my pom file to get it to run. All I want for now is to run them as unit tests in my IDE (Eclipse). Could someone please help me.

 

Currently I have tried adding the following to my pom file:

 

 

 

 

     <dependency>
          <groupId>org.jboss.weld.arquillian.container</groupId>
          <artifactId>arquillian-weld-ee-embedded-1.1</artifactId>
          <version>1.1.2.AS7</version>
     </dependency>
     <dependency>
            <groupId>org.jboss.arquillian</groupId>
            <artifactId>arquillian-bom</artifactId>
            <version>1.0.1.Final</version>
            <scope>import</scope>
            <type>pom</type>
     </dependency>
     <dependency>
         <groupId>junit</groupId>
         <artifactId>junit</artifactId>
         <version>${junit.version}</version>
         <scope>test</scope>
     </dependency>
     <dependency>
          <groupId>org.jboss.arquillian.junit</groupId>
          <artifactId>arquillian-junit-container</artifactId>
          <version>1.0.0.Final</version>
     </dependency>

 

Any help would be greatly appreciated.