1 Reply Latest reply: Jun 25, 2012 1:50 PM by Lincoln Baxter III RSS

Richfaces plugin does not generate rich views

Max Korn Newbie

Hi all Forge users and devs,

I'd like create a basic Java EE application which uses Richfaces as JSF library. So I composed the following script:

 

forge install-plugin richfaces;

 

richfaces setup;

  

new-project --named rich --topLevelPackage com.sample;

 

persistence setup --provider HIBERNATE --container JBOSS_AS7 ;

 

entity --named Customer;

field string --named firstName;

field string --named lastName;

 

scaffold setup --scaffoldType faces;

 

scaffold from-entity;

 

The project "rich" successfully compiles, however having a look in the views created from scaffold, I can see plain JSF is used and no rich: tags are used.

 

<ui:define name="main">
<h:panelGrid columnClasses="label,component,required" columns="3">
<h:outputLabel for="customerBeanCustomerFirstName" value="First Name:"/>
<h:outputText id="customerBeanCustomerFirstName" value="#{customerBean.customer.firstName}"/>
<h:outputText/>
<h:outputLabel for="customerBeanCustomerLastName" value="Last Name:"/>
<h:outputText id="customerBeanCustomerLastName" value="#{customerBean.customer.lastName}"/>
<h:outputText/>
</h:panelGrid>

 

<div class="buttons">
<h:link value="View All" outcome="search"/>
<h:link value="Edit" outcome="create" includeViewParams="true"/>
<h:link value="Create New" outcome="create"/>
</div>
</ui:define>

Also into web.xml no richfaces intialization is performed. Is there something wrong in my script ?

maybe should I use a different scaffold for richfaces GUIs ?

scaffold setup --scaffoldType richfaces (just guessing)

Thanks

Max