1 Reply Latest reply: May 17, 2012 6:43 AM by Steven xu RSS

JBoss AS 7.1.0 Final - ClassNotFoundException

Steven xu Newbie

I using IBM's JDK and need to using "system" module.

 

In JBoss7.0.2 Final

I  defined <module name="system"> in my module.xml, it works fine.

 

But it does not work in JBoss7.1.0 Final

I have tried define  the <system> element, but I still getting ClassNotFoundException

 

module.xml:

<dependencies>

        <system export="true">

            <paths>

                      <path name="com/ibm/xml/crypto/dsig/dom" />

                      <path name="com/ibm/xml/crypto/dsig" />

                      <path name="com/ibm/xml/crypto" />

                      <path name="com/ibm/jsse2" />

            </paths>

        </system>

</dependencies>

 

 

Exception:

03:18:47,468 ERROR [org.apache.catalina.connector.CoyoteAdapter] (http--0.0.0.0-8443-1) An exception or error occurred in the container during the request processing: java.lang.ExceptionInInitializerError

        at java.lang.J9VMInternals.initialize(J9VMInternals.java:222) [vm.jar:6.0]

        ...

        ...

        at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:154) [jboss-as-web-7.1.0.Final.jar:7.1.0.Final]

        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:155) [jbossweb-7.0.10.Final.jar:]

        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) [jbossweb-7.0.10.Final.jar:]

        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) [jbossweb-7.0.10.Final.jar:]

        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:368) [jbossweb-7.0.10.Final.jar:]

        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:877) [jbossweb-7.0.10.Final.jar:]

        at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:671) [jbossweb-7.0.10.Final.jar:]

        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:930) [jbossweb-7.0.10.Final.jar:]

        at java.lang.Thread.run(Thread.java:736) [vm.jar:6.0]

Caused by: javax.xml.crypto.NoSuchMechanismException: class configured for XMLSignatureFactory(provider: IBMXMLCRYPTO)cannot be found.

 

        at javax.xml.crypto.dsig.XMLDSigSecurity.doGetImpl(Unknown Source) [xmlsec-1.4.5.jar:]

        at javax.xml.crypto.dsig.XMLDSigSecurity.getImpl(Unknown Source) [xmlsec-1.4.5.jar:]

        at javax.xml.crypto.dsig.XMLDSigSecurity.getImpl(Unknown Source) [xmlsec-1.4.5.jar:]

        at javax.xml.crypto.dsig.XMLSignatureFactory.findInstance(Unknown Source) [xmlsec-1.4.5.jar:]

        at javax.xml.crypto.dsig.XMLSignatureFactory.getInstance(Unknown Source) [xmlsec-1.4.5.jar:]

        ...

        at java.lang.J9VMInternals.initializeImpl(Native Method) [vm.jar:6.0]

        at java.lang.J9VMInternals.initialize(J9VMInternals.java:200) [vm.jar:6.0]

        ... 14 more

Caused by: java.lang.ClassNotFoundException: com.ibm.xml.crypto.dsig.dom.FactoryImpl

        at java.lang.Class.forNameImpl(Native Method) [vm.jar:6.0]

        at java.lang.Class.forName(Class.java:136) [vm.jar:6.0]

        ... 22 more

 

 

Thanks in advance!