1 Reply Latest reply: May 2, 2012 6:09 AM by tatupirsa tatu RSS

Jboss + apache + mod_jk + axis2 --- axis2 doesn't work ---

tatupirsa tatu Newbie

Hi,

I have centos 6.0 server with a JBoss 4.2.2.GA + Apache/2.2.15 + mod_jk-1.2.31-httpd-2.2.x.so.

I have an application with some virtualhost and this mod_jk configuration:

 

-- mod_jk.conf

    LoadModule jk_module modules/mod_jk.so

   

    JkWorkersFile conf/workers.properties

    JkLogFile logs/mod_jk.log

    JkLogLevel debug

    JkLogStampFormat  "[%a %b %d %H:%M:%S %Y]"

    JkRequestLogFormat "%w %V %T"

    JkShmFile logs/jk.shm

   

    JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories

    <Location /jkstatus/>

        JkMount status

        Order deny,allow

        Allow from 127.0.0.1

    </Location>

   

    JkMountCopy all

    <VirtualHost 172.25.0.118:80>

            JkMount /status nodo1

    </VirtualHost>

   

    <VirtualHost application1.es:80>

        ServerName application1.es

        DocumentRoot /opt/jboss/jboss-4.2.2.GA/server/default/deploy/application.ear/application1.war/

        ErrorLog /logs/app/application1_log_errores

        CustomLog /logs/app/application1_log_accesos common

   

        JkMount /* nodo1

   

        RewriteEngine on

        RewriteCond %{HTTP_HOST} ^application1.es$

        RewriteRule ^/$ /application1/indexAction.do [R]

    </VirtualHost>

   

    <VirtualHost application2.es:80>

        ServerName application2.es

        ServerAlias application2.es

        DocumentRoot /opt/jboss/jboss-4.2.2.GA/server/default/deploy/application.ear/

        ErrorLog /logs/app/application2_log_errores

        CustomLog /logs/app/application2_log_accesos common

   

        JkMount /* nodo1

   

        RewriteEngine on

        RewriteCond %{HTTP_HOST} ^application2.es$

        RewriteRule ^/$ /application2/indexAction.do [R]

    </VirtualHost>

   

    <VirtualHost application3:80>

        ServerName application3

        ServerAlias application3

        DocumentRoot /opt/jboss/jboss-4.2.2.GA/server/default/deploy/application.ear/axis2.war/

        ErrorLog /logs/app/application3_log_errores

        CustomLog /logs/app/application3_log_accesos common

   

        JkMount /* nodo1

   

        RewriteEngine on

        RewriteCond %{HTTP_HOST} ^application3$

        RewriteRule ^/$ /services/Recepcion.RecepcionHttpSoap11Endpoint [R]

    </VirtualHost>

 

-- uriworkermap.properties

    # Mount the Servlet context to the ajp13 worker

    /jmx-console=nodo1

    /jmx-console/*=nodo1

    /web-console=nodo1

    /web-console/*=nodo1

    /status=nodo1

    /application1/*=nodo1

    /application1/indexAction.do=nodo1

    /*=nodo1

    /axis2/*=nodo1

 

-- workers.properties

    workers.tomcat_home=/opt/jboss/jboss-4.2.2.GA

    workers.java_home=/opt/jboss/jdk64/jdk1.6.0_30/bin/java

   

    worker.list=nodo1,nodo2,status

    worker.status.type=status

   

    worker.nodo1.port=38009

    worker.nodo1.host=0.0.0.0

    worker.nodo1.type=ajp13

    worker.nodo1.ping_mode=A

 

 

Application1 and application2 work OK, but application3 doesn't work.

The application3 doesn't load, there isn't any error in explorer or logs; only shows a white page.

The access log shows this, HTTP 400, NOT FOUND:

-- [27/Apr/2012:11:04:46 +0200] "GET /services/Recepcion.RecepcionHttpSoap11Endpoint HTTP/1.1" 400 -

 

Any idea?

Why doesn't work axis with mod_jk?

 

Thanks,

tatu

  • 1. Re: Jboss + apache + mod_jk + axis2 --- axis2 doesn't work ---
    tatupirsa tatu Newbie

    Hi,

    I have been trying but I have not fixed anything.

    I have found and configure in this file "axis2.war/WEB-INF/conf/axis2.xml" some things:

     

    From:

    <!-- Following parameter will set the host name for the epr-->

    <!--<parameter name="hostname" locked="true">myhost.com</parameter>-->

     

    To:

    <parameter name="hostname" locked="true">application3.es</parameter>

     

    From:

    <!-- If you have a front end host which exposes this webservice using a different public URL  -->

    <!-- use this parameter to override autodetected url -->

    <!--<parameter name="httpFrontendHostUrl">https://someotherhost/context</parameter>-->

     

    To:

    <parameter name="httpFrontendHostUrl">http://application3.es/</parameter>

     

    From:

    <!--<parameter name="contextRoot">axis2</parameter>-->

     

    To:                           

    <parameter name="contextRoot">axis2</parameter>

     

     

    I have trying too with other parameters but doesn't work.

     

    Any idea?

    Thanks.