1 Reply Latest reply: Apr 28, 2012 9:45 AM by hantsy bai RSS

NetBeans 7.1 + Seam 3.1.0

Bruno Toffolo Newbie

Hey buddies, how are you?

 

I have been trying to configure NetBeans 7.1 to work with Seam under Windows 7 x64.

Recently I have searched for discussions in this forum and found some unhelpful ones (like this one). Googling it I could find some resources and many broken links (such as this seam-gen plugin and this facelets plugin) accompanied by some unsuccessful tutorials (including an official NetBeans tutorial non-official references like this one and even this PT-BR one).

 

Many of them were conceived using Seam 2.2 and pretty old versions of NetBeans (like 6.0 or 6.5). I know much has changed since they were published, and as Seam 3 provides independent libraries for each module, packaged in a bundled distribution, I am having some issues integrating it with NetBeans.

 

My only current needs are that Seam version is 3 (preferrably 3.1.0) and NetBeans version needs to be recent (like 7.0 or 7.1). I don't have any limitations regarding the server (I could perfectly adopt JBoss AS, but Glassfish would be nicer).

 

Can anyone help me on how to integrate NetBeans and Seam 3?

Nothing I tried until now was worth a shot. =(

 

Thanks in advance!

Have a great week,