2 Replies Latest reply: Apr 23, 2012 8:48 AM by Max Rydahl Andersen RSS

Eclipse software update: NPE popup on saving edited source

Karsten Wutzke Expert

Hello all,

 

I've upgraded Eclipse 3.7 to the latest available software. I've never had big problems with that. I checked all that could be updated.

 

Now however, I keep getting the following popup:

 

eclipse-update-npe-popup.png

 

Exception (copied from the Eclipse .log):

 

!ENTRY org.eclipse.jface 4 2 2012-04-20 08:54:58.618
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
!STACK 0
java.lang.NullPointerException
    at com.sun.enterprise.jst.server.sunappsrv.actions.PreludeUpdateCenterAction.accept(PreludeUpdateCenterAction.java:171)
    at com.sun.enterprise.jst.server.sunappsrv.actions.AppServerContextAction.selectionChanged(AppServerContextAction.java:238)
    at org.eclipse.ui.actions.SelectionProviderAction.selectionChanged(SelectionProviderAction.java:143)
    at org.eclipse.jface.viewers.Viewer$2.run(Viewer.java:164)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
    at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
    at org.eclipse.jface.viewers.Viewer.fireSelectionChanged(Viewer.java:162)
    at org.eclipse.jface.viewers.StructuredViewer.updateSelection(StructuredViewer.java:2188)
    at org.eclipse.jface.viewers.StructuredViewer.setSelection(StructuredViewer.java:1725)
    at org.eclipse.jface.viewers.TreeViewer.setSelection(TreeViewer.java:1139)
    at org.eclipse.ui.navigator.CommonViewer.setSelection(CommonViewer.java:377)
    at org.eclipse.jface.viewers.Viewer.setSelection(Viewer.java:394)
    at org.eclipse.wst.server.ui.internal.cnf.ServerDecoratorsHandler$1.run(ServerDecoratorsHandler.java:58)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

 

Note this appears twice in the log, thus the two NPEs in the popup.

 

When I edit any Java file a popup dialog appears on every save operation while the JBoss 7 server is running. It could hardly be more annoying to be honest!

 

What's wrong here? Who's responsible? Is it a JBT issue at all? I have no idea.

 

I cannot revert to the previous install, it fails with some error that some older Eclipse repos aren't found or so.

 

Karsten