1 Reply Latest reply: Sep 6, 2012 9:46 AM by rodolfo tocci RSS

JBoss 7.0.2 soap rewrite issue

rodolfo tocci Newbie

Dear All,

I have a problem with the soap address rewrite .

My setup is as follows:

S.O. : centos

A.S. : JBoss 7.0.2 - standalone private network

Upstream of the AS is a Hardware Load Balancer that receives requests to https and http runs.

The address rewrite is done properly and then I find the DNS in my WSDL associated with the LB, but the protocol is not maintained.

so https://mydns/mycontext/myservice?wsdl

is translated into

<soap12:address location=http://mydns/mycontext/myservice />

After reading the documentation I have changed the subsystem webservice

<subsystem xmlns="urn:jboss:domain:webservices:1.0">

             <modify-wsdl-address>true</modify-wsdl-address>

             <wsdl-host>mydns</wsdl-host>

        </subsystem>

i's not working.

thanks in advance

  • 1. Re: JBoss 7.0.2 soap rewrite issue
    rodolfo tocci Newbie

    I've solved using this configuration

     

    <subsystem xmlns="urn:jboss:domain:web:1.0" default-virtual-server="default-host">

                <connector name="http" protocol="HTTP/1.1" socket-binding="http" scheme="https" proxy-name="MYDNS" proxy-port="443"/>

                <connector name="http1" protocol="HTTP/1.1" socket-binding="http1" scheme="http"/>

                <virtual-server name="default-host" enable-welcome-root="true">

                    <alias name="localhost"/>

                </virtual-server>

            </subsystem>

            <subsystem xmlns="urn:jboss:domain:webservices:1.0" xmlns:javaee="http://java.sun.com/xml/ns/javaee" xmlns:jaxwsconfig="urn:jboss:jbossws-jaxws-config:4.0">

                <wsdl-host>

                    MYDNS

                </wsdl-host>

                <modify-wsdl-address>

                    true

                </modify-wsdl-address>

    </subsystem>

    ....

    <socket-binding-group name="standard-sockets" default-interface="public">

            <socket-binding name="http" port="8080"/>

            <socket-binding name="http1" port="9080"/>

          .........

        </socket-binding-group>

     

    the LB forward the request on http://myPrivateHostIp:8080/.....