1 Reply Latest reply: Apr 18, 2012 2:26 PM by Phani Reddy V RSS

JBoss 5.1: Hibernate with JPA

jazb Newbie

I've got two questions to ask regarding JBoss 5.1. We are in process of migrating from JBoss 4.2 to JBoss 5.1.

 

We are also using Java 1.6 and JPA 2.0 with Hibernate 3.6 as the provider.

 

My questions are:

  1. Is it possible to use Hibernate 3.6+ with JBoss 5.1. If yes, then how?
  2. What about JPA 2.0? I know that JBoss 5.1 comes with JPA 1.0 compatibility. Can we use JPA2?

 

 

And as we can not do any kind of configuration to the JBoss installation, all the fixes need to be done in our application only.

 

 

Thanks in advance,

 

JassB