0 Replies Latest reply: Apr 9, 2012 1:21 PM by Ken Barnes RSS

JBOSS-WS client timestamp verification

Ken Barnes Newbie

I am using jbossws-native-3.1.2  and have a web service (SERVICE A) with ws-security for a timestamp on jboss running 5.1.0.GA.  I can use soapUI and hit the service with the required settings and all works. I also have anther web service (SERVICE B) deployment in another jboss container that makes a client connection to SERVICE A.  When I use SOAP to call SERVICE B and it attempts to make the call to A, the call goes out and returns with a valid soap envelope but gets a WSSecurityException: Invalid timestamp, message claimed to be created after now because SERVICE A's server is a minute faster. 


SERVICE A jboss-wsse-server.xml

<jboss-ws-security xmlns="http://www.jboss.com/ws-security/config"

                         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                         xsi:schemaLocation="http://www.jboss.com/ws-security/config

                         http://www.jboss.com/ws-security/schema/jboss-ws-security_1_0.xsd">

     <timestamp-verification createdTolerance="300000" warnCreated="false" expiresTolerance="300000" warnExpires="false" />

     <config>

        <timestamp ttl="30000"/>

        <requires/>

     </config>

   </jboss-ws-security>

 

I am not specifying any constaints on the client jboss that makes the call to A, but it is verifying the timestamp anyway. Are there any settings on the server to give

it a tolerance for the client like I did the server (the actual jboss).  Would It be in $JBOSS_HOME\server\default\deployers\jbossws.deployer?

Thanks