1 2 3 Previous Next 36 Replies Latest reply: Aug 5, 2013 4:01 PM by amiller RSS

CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?

rsmeral Newbie

Specifically, this occurred in the Booking example from Seam2.2, which has been migrated to EAP6.

 

The only properties defined in persistence.xml are:

 

<property name="hibernate.cache.provider_class" value="org.hibernate.cache.HashtableCacheProvider"/>      
<property name="hibernate.transaction.manager_lookup_class" value="org.hibernate.transaction.JBossTransactionManagerLookup"/>
<property name="jboss.as.jpa.providerModule" value="hibernate3-bundled" />

 

All the required Hibernate 3.3 libraries are bundled with the application and there is an exclusion of "org.hibernate" defined in jboss-deployment-structure.xml.

 

The application fails to deploy, while the server log contains:

 

14:54:13,042 WARN  [org.jboss.modules] (MSC service thread 1-4) Failed to define class org.jboss.as.jpa.hibernate3.infinispan.InfinispanRegionFactory in Module "deployment.jboss-seam-booking.ear:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/jboss/as/jpa/hibernate3/infinispan/InfinispanRegionFactory (Module "deployment.jboss-seam-booking.ear:main" from Service Module Loader)
...
Caused by: java.lang.NoClassDefFoundError: org/hibernate/cache/infinispan/InfinispanRegionFactory
...
Caused by: java.lang.ClassNotFoundException: org.hibernate.cache.infinispan.InfinispanRegionFactory from [Module "deployment.jboss-seam-booking.ear:main" from Service Module Loader]

 

Explicitly disabling the second-level cache and query cache in persistence.xml with

 

<property name="hibernate.cache.use_second_level_cache" value="false"/>
<property name="hibernate.cache.use_query_cache" value="false"/>

 

does not change the behaviour.

 

Apparently, AS7 enables the Infinispan subsystem and looks for its region factory class which, in case of bundled Hibernate 3.3 and explicitly disabled second-level cache, it probably shouldn't.

Did I miss something, or is this a bug?

 

Full server log and  EAR attached.

  • 1. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    I think that prior to AS 7.1.1, the bundled Hibernate 3.3 jars would be ignored by the Seam application.  I fixed that bug recently, so that javax.persistence.Persistence (which Seam uses to get the entitymanager or entitymanagerfactory) will be aware of the package persistence providers jars (whether its Hibernate 3.3 or OGM or whatever).

     

    You cannot use the Infinispan cache with Hibernate 3.3 (Infinispan integration comes in later Hibernate releases).

     

    Scott

  • 2. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Marek Schmidt Newbie

    Scott, that's not the point. We don't want to use infinispan cache. Neither the app nor the persistence.xml ask for it. But still it fails to deploy with "Failed to define class org.jboss.as.jpa.hibernate3.infinispan.InfinispanRegionFactory". So how can we configure it to not attempt to use infinispan cache for our bundled hibernate3.3?

  • 3. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    Ahh, agreed.  This is an AS7 bug.  Can you create a jira for this and refeference this forum post.

     

    I think that the Infinispan module references should be optional (that should work around this I think).  If you want to hack past this, you could try updating your as7/modules/org/jboss/as/jpa/hibernate/3/module.xml as follows:

     

     

    <?xml version="1.0" encoding="UTF-8"?>
    
    <!--
      ~ JBoss, Home of Professional Open Source.
      ~ Copyright 2010, Red Hat, Inc., and individual contributors
      ~ as indicated by the @author tags. See the copyright.txt file in the
      ~ distribution for a full listing of individual contributors.
      ~
      ~ This is free software; you can redistribute it and/or modify it
      ~ under the terms of the GNU Lesser General Public License as
      ~ published by the Free Software Foundation; either version 2.1 of
      ~ the License, or (at your option) any later version.
      ~
      ~ This software is distributed in the hope that it will be useful,
      ~ but WITHOUT ANY WARRANTY; without even the implied warranty of
      ~ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
      ~ Lesser General Public License for more details.
      ~
      ~ You should have received a copy of the GNU Lesser General Public
      ~ License along with this software; if not, write to the Free
      ~ Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
      ~ 02110-1301 USA, or see the FSF site: http://www.fsf.org.
      -->
    
    <!-- contains the JPA integration classes for Hibernate 3.x --> 
    <module xmlns="urn:jboss:module:1.1" name="org.jboss.as.jpa.hibernate" slot="3">
        <properties>
            <property name="jboss.api" value="private"/>
        </properties>
    
        <resources>
            <resource-root path="jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar"/>
            <!-- Insert resources here -->
        </resources>
    
        <dependencies>
            <module name="javax.annotation.api"/>
            <module name="javax.persistence.api"/>
            <module name="javax.transaction.api"/>
            <module name="org.hibernate" slot="3" optional="true" services="import"/>  <!-- org.hibernate:3 must be created manually with Hibernate 3 jars -->
            <module name="org.hibernate.validator"/>
            <module name="org.infinispan" optional="true"/>
            <module name="org.jboss.as.clustering.infinispan" optional="true"/>
            <module name="org.jboss.as.jpa.spi"/>
            <module name="org.jboss.as.naming"/>
            <module name="org.jboss.as.server"/>
            <module name="org.jboss.jandex"/>
            <module name="org.jboss.logging"/>
            <module name="org.jboss.msc"/>
            <module name="org.jboss.vfs"/>
        </dependencies>
    </module>
    
  • 4. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    John Genoese Newbie

    Greetings, Scott.

    Is there a step I missed here? I get

     

    Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[32,81]

    Message: Failed to add resource root 'jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar' at path 'jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar'

        at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:898)

        at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:854)

        at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:676)

        at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:548)

        at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:287)

        ... 17 more

     

    I didn't see anything mentioning a download of the 'jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar' artifact. Did you assume that part?

     

    Just for reference, here's the relevant part of my module.xml:

     

    <module xmlns="urn:jboss:module:1.1" name="org.jboss.as.jpa.hibernate" slot="3">

        <properties>

            <property name="jboss.api" value="private"/>

        </properties>

     

     

        <resources>

            <resource-root path="jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar"/>

            <!-- Insert resources here -->

        </resources>

     

     

        <dependencies>

            <module name="javax.annotation.api"/>

            <module name="javax.persistence.api"/>

            <module name="javax.transaction.api"/>

            <module name="org.hibernate" slot="3" optional="true" services="import"/>  <!-- org.hibernate:3 must be created manually with Hibernate 3 jars -->

            <module name="org.hibernate.validator"/>

            <module name="org.infinispan"/>

            <module name="org.jboss.as.clustering.infinispan" optional="true"/>

            <module name="org.jboss.as.jpa.spi"/>

            <module name="org.jboss.as.naming"/>

            <module name="org.jboss.as.server"/>

            <module name="org.jboss.jandex"/>

            <module name="org.jboss.logging"/>

            <module name="org.jboss.msc"/>

            <module name="org.jboss.vfs"/>

        </dependencies>

    </module>

  • 5. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    Correct, you don't need to download anything (jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar contains some integration code and is not Hibernate).  Try adding optional="true" for:

     

      <module name="org.infinispan"/>

     

    I tried to color code the lines I changed but the xml chroma coding took over. 

     

     


  • 6. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    John Genoese Newbie

    Sorry, Scott. No joy.

     

    module.xml:

     

    <module xmlns="urn:jboss:module:1.1" name="org.jboss.as.jpa.hibernate" slot="3">

        <properties>

            <property name="jboss.api" value="private"/>

        </properties>

     

     

        <resources>

            <resource-root path="jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar"/>

            <!-- Insert resources here -->

        </resources>

     

     

        <dependencies>

            <module name="javax.annotation.api"/>

            <module name="javax.persistence.api"/>

            <module name="javax.transaction.api"/>

            <module name="org.hibernate" slot="3" optional="true" services="import"/>  <!-- org.hibernate:3 must be created manually with Hibernate 3 jars -->

            <module name="org.hibernate.validator"/>

            <module name="org.infinispan" optional="true"/>

            <module name="org.jboss.as.clustering.infinispan" optional="true"/>

            <module name="org.jboss.as.jpa.spi"/>

            <module name="org.jboss.as.naming"/>

            <module name="org.jboss.as.server"/>

            <module name="org.jboss.jandex"/>

            <module name="org.jboss.logging"/>

            <module name="org.jboss.msc"/>

            <module name="org.jboss.vfs"/>

        </dependencies>

    </module>

     

     

    Results:

     

    Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[32,81]

    Message: Failed to add resource root 'jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar' at path 'jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar'

            at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:898) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:854) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:676) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:548) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:287) [jboss-modules.jar:1.1.1.GA]

            ... 17 more

  • 7. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    Hmm, parseError is actually a typo in the module.xml.  Can you attach the module.xml so I can diff it against mine.

  • 9. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    I don't see the typo, could you try removing the *.index files in your as7/modules/org/jboss/as/jpa/hibernate/3 folder.

  • 10. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    John Genoese Newbie

    Once again, no joy.

     

    Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[32,81]

    Message: Failed to add resource root 'jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar' at path 'jboss-as-jpa-hibernate3-7.1.2.Final-SNAPSHOT.jar'

            at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:898)

            at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:854)

            at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:676)

            at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:548)

            at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:287)

            ... 17 more

     

     

    $:pwd

    /MDR.Development/jboss-as-7.1.1.Final/modules/org/jboss/as/jpa/hibernate/3

    [jgenoese@mdr:/MDR.Development/jboss-as-7.1.1.Final/modules/org/jboss/as/jpa/hibernate/3] [bash:88] Wed Mar 28 12:30:43

    $:ls -l

    total 48

    -rw-r--r--  1 jgenoese  staff  20051 Mar 10 01:14 jboss-as-jpa-hibernate3-7.1.1.Final.jar

    -rw-r--r--  1 jgenoese  staff   2300 Mar 28 11:50 module.xml

    [jgenoese@mdr:/MDR.Development/jboss-as-7.1.1.Final/modules/org/jboss/as/jpa/hibernate/3] [bash:89] Wed Mar 28 12:30:47

    $:

  • 11. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    Sorry, I must of done this to you.  in your module.xml, change from jboss-as-jpa-hibernate3-7.1.2.Final.jar to jboss-as-jpa-hibernate3-7.1.1.Final.jar (to reflect the actual jar name).

  • 12. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    John Genoese Newbie

    Once again, no joy. Here's the whole sorry pantload:

     

    12:43:09,353 WARN  [org.jboss.modules] (MSC service thread 1-3) Failed to define class org.jboss.as.jpa.hibernate3.infinispan.SharedInfinispanRegionFactory in Module "deployment.waimap.ear:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/jboss/as/jpa/hibernate3/infinispan/SharedInfinispanRegionFactory (Module "deployment.waimap.ear:main" from Service Module Loader)

            at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:396) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:243) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:73) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.Module.loadModuleClass(Module.java:517) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:182) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.as.jpa.hibernate3.HibernatePersistenceProviderAdaptor.<clinit>(HibernatePersistenceProviderAdaptor.java:49)

            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [classes.jar:1.6.0_30]

            at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) [classes.jar:1.6.0_30]

            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) [classes.jar:1.6.0_30]

            at java.lang.reflect.Constructor.newInstance(Constructor.java:513) [classes.jar:1.6.0_30]

            at java.lang.Class.newInstance0(Class.java:355) [classes.jar:1.6.0_30]

            at java.lang.Class.newInstance(Class.java:308) [classes.jar:1.6.0_30]

            at org.jboss.as.jpa.processor.PersistenceProviderProcessor.deploy(PersistenceProviderProcessor.java:101)

            at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

            at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

            at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_30]

            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_30]

            at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_30]

    Caused by: java.lang.NoClassDefFoundError: org/jboss/as/jpa/hibernate3/infinispan/InfinispanRegionFactory

            at java.lang.ClassLoader.defineClass1(Native Method) [classes.jar:1.6.0_30]

            at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) [classes.jar:1.6.0_30]

            at java.lang.ClassLoader.defineClass(ClassLoader.java:615) [classes.jar:1.6.0_30]

            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [classes.jar:1.6.0_30]

            at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:327) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:391) [jboss-modules.jar:1.1.1.GA]

            ... 23 more

    Caused by: java.lang.ClassNotFoundException: org.jboss.as.jpa.hibernate3.infinispan.InfinispanRegionFactory from [Module "deployment.waimap.ear:main" from Service Module Loader]

            at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398) [jboss-modules.jar:1.1.1.GA]

            at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120) [jboss-modules.jar:1.1.1.GA]

            ... 29 more

     

    At this point, I think it' reasonable for me to conclude that this is idiosyncratic to my particular environment/EAR. The same think happened on my Linux site For laughs, here's my persistence.xml:

     

    <?xml version="1.0" encoding="UTF-8"?>

    <!-- Persistence deployment descriptor for dev profile -->

    <persistence xmlns="http://java.sun.com/xml/ns/persistence"

      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

      xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd"

      version="1.0">

      <persistence-unit name="waimap_pu" transaction-type="JTA">

                        <provider>org.hibernate.ejb.HibernatePersistence</provider>

                        <jta-data-source>java:jboss/datasources/waimap_ds</jta-data-source>

      <properties>

      <property name="hibernate.dialect" value="org.hibernate.dialect.PostgreSQLDialect" />

      <property name="hibernate.hbm2ddl.auto" value="validate" />

      <property name="hibernate.show_sql" value="true" />

      <property name="hibernate.format_sql" value="true" />

      <property name="jboss.entity.manager.factory.jndi.name"

      value="java:app/waimap_puEntityManagerFactory" />

      <property name="hibernate.default_schema" value="waimap" />

      <property name="hibernate.listeners.envers.autoRegister" value="false"/>

                <property name="jboss.as.jpa.providerModule" value="hibernate3-bundled" />

      </properties>

      </persistence-unit>

     

    </persistence>

     

    Here my jboss-deployment-structure.xml

    <jboss-deployment-structure xmlns="urn:jboss:deployment-structure:1.0">

     

     

      <deployment>

      <dependencies>

      <module name="org.bouncycastle" slot="main" export="true"/>

      <module name="org.apache.log4j" export="true" />

      <module name="org.dom4j" export="true" />

      <module name="org.apache.commons.logging" export="true" />

      <module name="org.apache.commons.collections" export="true" />

      </dependencies>

      </deployment>

     

      <sub-deployment name="waimap.war-0.3.0.war">

      <exclusions>

      <module name="javax.faces.api" slot="main" />

      <module name="com.sun.jsf-impl" slot="main" />

      <module name="javax.faces.api" slot="1.2" />

      <module name="com.sun.jsf-impl" slot="1.2" />

      </exclusions>

      <dependencies>

      <module name="deployment.waimap.ear.waimap.ejb-0.3.0.jar"/>

      <module name="deployment.waimap.ear.jboss-seam-2.2.2.Final.jar" />

      <!--

                                  <module name="javax.faces.api" slot="1.2" />

                                  <module name="com.sun.jsf-impl" slot="1.2" />

                                   -->

      </dependencies>

      </sub-deployment>

     

      <sub-deployment name="waimap-client.war-0.3.0.war">

      <exclusions>

      <module name="javax.faces.api" slot="main" />

      <module name="com.sun.jsf-impl" slot="main" />

      <module name="javax.faces.api" slot="1.2" />

      <module name="com.sun.jsf-impl" slot="1.2" />

      </exclusions>

      <dependencies>

      <!-- <module name="deployment.waimap.ear.waimap.war-0.3.0.war" /> -->

      <module name="deployment.waimap.ear.waimap.ejb-0.3.0.jar" />

      <module name="deployment.waimap.ear.jboss-seam-2.2.2.Final.jar" />

      <!--

                                  <module name="javax.faces.api" slot="1.2" />

                                  <module name="com.sun.jsf-impl" slot="1.2" />

                                  -->

      </dependencies>

      </sub-deployment>

     

    </jboss-deployment-structure>

     

    The whole object of the game is to run a Seam 2.2.x App through jboss 7.1.1.Final. 7.1.0.FInal is working fine.

  • 13. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    I see the bug, its in org.jboss.as.jpa.hibernate3.HibernatePersistenceProviderAdaptor.

  • 14. Re: CNFE: InfinispanRegionFactory in app. using Hibernate 3.3 on AS 7.1.1. Bug?
    Scott Marlow Master

    Could you try adding one more persistence unit property to see if it helps here.  Try setting jboss.as.jpa.managed to false in your persistence.xml:

     

     

    <?xml version="1.0" encoding="UTF-8"?>
    <!-- Persistence deployment descriptor for dev profile -->
    <persistence xmlns="http://java.sun.com/xml/ns/persistence"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd"
      version="1.0">
      <persistence-unit name="waimap_pu" transaction-type="JTA">
                        <provider>org.hibernate.ejb.HibernatePersistence</provider>
                        <jta-data-source>java:jboss/datasources/waimap_ds</jta-data-source>
      <properties>
      <property name="hibernate.dialect" value="org.hibernate.dialect.PostgreSQLDialect" />
      <property name="hibernate.hbm2ddl.auto" value="validate" />
      <property name="hibernate.show_sql" value="true" />
      <property name="hibernate.format_sql" value="true" />
      <property name="jboss.entity.manager.factory.jndi.name"
      value="java:app/waimap_puEntityManagerFactory" />
      <property name="hibernate.default_schema" value="waimap" />
      <property name="hibernate.listeners.envers.autoRegister" value="false"/>
                <property name="jboss.as.jpa.providerModule" value="hibernate3-bundled" />
              <property name="jboss.as.jpa.managed" value="false" />
    
      </properties>
      </persistence-unit>
    
    </persistence>
    

     

    That might workaround the error.

1 2 3 Previous Next