3 Replies Latest reply: Nov 10, 2011 4:11 PM by Prabhat Jha RSS

Does JBoss 5.1.1 AS support deployment of JBoss Portal 2.7.1

Vikran Hedge Newbie

Hi All,

 

I request any of the experts to let me know if Jboss EAP 5.1.1 AS supports Jboss-portal 2.7.x deployment? if yes, can I you giude me through the steps to accomplish the deployment of Jboss-portal sar(2.7.x) on Jboss 5.1.1 AS

 

Thanks in Advance!

 

Regards'

Vic

  • 1. Re: Does JBoss 5.1.1 AS support deployment of JBoss Portal 2.7.1
    Prabhat Jha Master

    JBoss Portal 2.7 series has not been in active development for a long time. The supported version that runs with EAP 5.1.1 is EPP 5.1.1 If you have access to EAP 5.1.1 that implies you are a Red Hat customer so you should have access to EPP bits.

  • 2. Re: Does JBoss 5.1.1 AS support deployment of JBoss Portal 2.7.1
    Vikran Hedge Newbie

    Thanks Prabhat for reply!

     

    But, scenario here is, we are migrating our application from JEAP 4.0.5 AS to JEAP 5.1.1 AS. So, we had a portal piece backed by jboss-portal-ha.sar which is running fine on JEAP 4.0.5 AS with JRE 5. But, after migration to JEAP 5.1.1 AS, jboss-portal-ha.sar is not getting deployed on new environment(JEAP 5.1.1 AS with JDK 6) and hence we are not able to bring up the portal piece of our application.

     

    As you said JEPP 5.1.1 has GateIn product integrated within it for supporting portal deployments, but I'm not sure if that need some code changes which I'm thinking like can be avioded if there is way to deploy jboss-portal-ha.sar(version 2.6.x/2.7.x) on JEAP 5.1.1. AS

     

    Any thoughts on this? As well, I believe, we need a seperate license to be bought for JEPP 5.1.1 other than JEAP 5.1.1!

     

    Regards'

    Vic

  • 3. Re: Does JBoss 5.1.1 AS support deployment of JBoss Portal 2.7.1
    Prabhat Jha Master

    You are correct. You would have to buy a seperate subscription (not license - remember it's OSS) for EPP 5.1.1 which is the version compatible with EAP 5.1.1. Also keep in mind that when you get EPP 5.1.1, you get everything bundled properly and tuned so you don't need to do any of those manual integration.