1 Reply Latest reply: Sep 27, 2011 12:06 AM by jaikiran pai RSS

    Unable to deploy and initialize datasource for MySQL

    Max Korn Newbie

      Hi all,

      I'm trying to create a datasource for mysql (5.1) using JBoss 7.0.2. I've gone through the following issues:

      1. If I deploy the mysql-connector-java-5.1.16-bin.jar into the deployments folder the console logs:


      21:16:13,820 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1 -1) Deploying non-JDBC-compliant driver class com.mysql.jdbc.Driver (version 5.1)


      But the JDBC driver actually contains into the META-INF/services a file named java.sql.Driver with the JDBC driver name.


      2. The second issue is that if I try to add the datasource using CLI, I have a generic error which says the datasource is already registered (?!?)


      [standalone@localhost:9999 /] /subsystem=datasources/data-source=MySqlDB:add(jndi-name="MySqlDB",pool-name="MySql_Pool",connection-url=jdbc:mysql://localhost:3306/database1,username=max ,password=korn,driver-class=com.mysql.jdbc.Driver,driver-name="mysql")


          "outcome" => "failed",

          "failure-description" => "Operation handler failed: org.jboss.msc.service.DuplicateServiceException: Service jboss.data-source-config.MySqlDB is already registered",

          "rolled-back" => true


      Maybe the CLI syntax I'm using is incorrect so the CLI tries to add the resource twice ......

      Any help to solve these issues ????

      Thanks a lot