4 Replies Latest reply: Sep 21, 2011 10:34 AM by Daniel Alonso RSS

    [UDP] StreamCorruptedException error traces

    Daniel Alonso Newbie

      I'm new at JBoss clustering and I've configured a JBoss server to run at clustering mode; now I'm receiving de following error traces several times each minute:


      10:31:20,992 ERROR [UDP] exception=java.io.StreamCorruptedException: invalid stream header
              at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:764)
              at java.io.ObjectInputStream.<init>(ObjectInputStream.java:277)
              at org.jgroups.protocols.UDP.handleIncomingUdpPacket(UDP.java:670)
              at org.jgroups.protocols.UDP.run(UDP.java:249)
              at java.lang.Thread.run(Thread.java:595)


      There's only one JBoos running at the moment. The server and installed application seems to run fine despite this error trace.


      I post my JBoss initial traces for more information:


      10:17:21,886 INFO  [Server] Starting JBoss (MX MicroKernel)...
      10:17:21,887 INFO  [Server] Release ID: JBoss [Zion] 4.0.5.GA (build: CVSTag=Branch_4_0 date=201107071506)
      10:17:21,888 INFO  [Server] Home Dir: /home/jboss
      10:17:21,888 INFO  [Server] Home URL: file:/home/jboss/
      10:17:21,889 INFO  [Server] Patch URL: null
      10:17:21,889 INFO  [Server] Server Name: teseo
      10:17:21,889 INFO  [Server] Server Home Dir: /home/jboss/server/teseo
      10:17:21,889 INFO  [Server] Server Home URL: file:/home/jboss/server/teseo/
      10:17:21,889 INFO  [Server] Server Log Dir: /home/jboss/server/teseo/log
      10:17:21,889 INFO  [Server] Server Temp Dir: /home/jboss/server/teseo/tmp
      10:17:21,890 INFO  [Server] Root Deployment Filename: jboss-service.xml
      10:17:22,273 INFO  [ServerInfo] Java version: 1.5.0_22,Sun Microsystems Inc.
      10:17:22,273 INFO  [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_22-b03,Sun Microsystems Inc.
      10:17:22,273 INFO  [ServerInfo] OS-System: Linux 2.6.18-164.el5,i386
      10:17:23,083 INFO  [Server] Core system initialized
      10:17:28,775 INFO  [WebService] Using RMI server codebase: http://Cletus.logesta.com:8083/
      10:17:28,789 INFO  [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      10:17:36,632 INFO  [ServiceEndpointManager] WebServices: jbossws-1.0.3.SP1 (date=200609291417)


      I've look for this error at the forums and I've found several old questions about this but no response.


      Does it exist any solution or procedure to detect the cause for this?


      Thanks in advance.