The relevant JIRA: https://issues.jboss.org/browse/SHRINKWRAP-261
Let's say we start by introducing a branch called "SHRINKWRAP-261" to introduce these new classes. I'll push it upstream and keep synced w/ master.
Also, as a general naming convention, for methods that return "this" object, we name without the "set" prefix. That'll keep things consistent w/ the rest of the ShrinkWrap projects, were were based on the article: http://martinfowler.com/bliki/FluentInterface.html.
So it'd be for example:
MavenDependency setCoordinates(String coordinates); // Nope >
MavenDependency coordinates(String coordinates); // Yep