3 Replies Latest reply: May 6, 2013 3:13 AM by A G RSS

Problems when moving from jdk 1.4 to jdk 1.6, from websphere to Jboss, from Oracle 10 to Oracle 11

sajiv kartha Newbie

We have an application that was running perfect in Websphere 5, with jdk 1.4 and Oracle as 10g.

 

Now, we want it to move to jdk 1.6, jboss 4, oracle 11g.  

When we compiled the code using jdk 1.6, we ran into a lot of compilation errors. Fixed them one by one.  Some of them were.

 

1) Some of the classes had to append new methods, like ConnectionWrapper.java, DetatchedResultSet.java etc

2) Customized class DropdownUtil.java had to do an explicit cast for a method "CompareTo"

3) DO objects that establish connection to databases, are now forced to implement the Serializable interface.

 

After all this, we were finally able to complile the code.  We are not sure how much the effect would be.  But, when we run the application, after the first page, we get some errors like

 

Caused by: java.sql.sqlexception : ORA-01830: date format picture ends before converting entire input string.

 

When we were running the application in websphere, we were having the default date pattern as dd-MM-yyyy, whereas in the database, we now see that it has the format of yyyy-MM-dd.

 

A program calls a query and it is this query that is throwing the above exception.  This works fine in websphere/jdk1.4/oracle 10g.

 

Is there anything that can be done

 

Thanks

 

  • 1. Problems when moving from jdk 1.4 to jdk 1.6, from websphere to Jboss, from Oracle 10 to Oracle 11
    Wolf-Dieter Fink Master

    Wow will be challenge to do three steps in once

     

    For giving an answer you have to provide a bit more informations ...

    - how do you store the date?

    - what type is it in java and DB

    - do you use JDBC or EJB2 CMP or JPA

     

    If you use CMP or JPA the persistence manager should do the work for you (if the configuration is correct)

  • 2. Problems when moving from jdk 1.4 to jdk 1.6, from websphere to Jboss, from Oracle 10 to Oracle 11
    sajiv kartha Newbie

    Well,

     

    Thanks for your reply.  I know I was asking too much at one go :-> and since I could not figure out if the errors I get are related to jdk1.6/jboss/11g, I had to frame my question like that.

     

    I could fix the sql exception, by putting in the correct version of ojdbc6.jar in the lib folder.  I had to remove the classes12.jar.  This removed the exceptions and I am getting the pages.

     

    By the by, I have other questions.  While running the application, I get exceptions like

     

    Caused by java.lang.IllegalArgumentException: setAttribute: Non-Serializable attribute

     

    This was thrown on almost all the DO classes that connect to the database.  Once I add  "implements Serializable" , I dont get any errors from DO classes.  But, in some of the adapter classes I do get this error.   Is there any reason for why we are forced to do add the Serializable interface.  Is this specific to JBoss4.x.

     

    Will adding this hit the performance in any way ?

     

    Thanks

     

  • 3. Re: Problems when moving from jdk 1.4 to jdk 1.6, from websphere to Jboss, from Oracle 10 to Oracle 11
    A G Newbie

    Hello  ,

     

    I am also working on a Migration project : Weblogic9.1 to JBoss 5.1

    Currently used JDK version is 1.5 . : migration will to JBK1.6

     

    My Query is :

    1. Can we directly migrate from JDK1.5 to JDK1.7  as JDK1.7 is the latest version ?

    2. As JBoss7.1 is the latest version wht cannot we use JBoss7.1 instead of JBoss5.1

     

    This is new query . Iwas not able to create a new post that is the reason I am just replying your mail .

    Please let me know procedure to cretae new post .

     

    Cheers

    Apurva