8 Replies Latest reply: Jul 6, 2010 6:32 AM by Andrew Dinn RSS

Can't build JBOSSTS_4_6_1_GA_CP05

testrot Newbie

Hello,

 

I downloaded the tag via the following URL:

http://anonsvn.jboss.org/repos/labs/labs/jbosstm/tags/JBOSSTS_4_6_1_GA_CP05

 

but can't build the jboss integrated jta transaction engine.

 

Executing ant jbossjta I get the following error:

 

...

[java] com.arjuna.mwlabs.ts.jbossatx.init:
     [java]      [echo] Initialising module atsintegration
     [java]      [echo] Source ID = unknown
     [java]      [echo] Version   = unknown
     [java]      [echo] Builder   = JBoss Inc. [tes] (Windows XP 5.1)
     [java]      [echo] Date      = 2010/Jun/30 18:34
     [java]      [echo] Notes     =
     [java]     [mkdir] Created dir: D:\home\workspaces\tes\jboss-transactions_4.6.1.GA_CP05\atsintegration\build\classes

 

     [java] BUILD FAILED
     [java] D:\home\workspaces\tes\jboss-transactions_4.6.1.GA_CP05\build.xml:148: The following error occurred while executing this line:
     [java] D:\home\workspaces\tes\jboss-transactions_4.6.1.GA_CP05\atsintegration\build.xml:162: No files specified for filelist.

 

     [java] Total time: 1 minute 28 seconds

 

BUILD FAILED
D:\home\workspaces\tes\jboss-transactions_4.6.1.GA_CP05\build.xml:96: The following error occurred while executing this line:
D:\home\workspaces\tes\jboss-transactions_4.6.1.GA_CP05\build.xml:53: Java returned: 1

 

Any suggestions?

 

Regards,

Martin

  • 1. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    Andrew Dinn Master

    testrot wrote:

    Any suggestions?

    First suggestion:

     

    Post to the correct forum. This one is for the developers who are implementing JBoss Transactions. You want the user forum

     

    Second suggestion:

     

    Ok, it's actually a question not a suggestion. Which version of JBossAS is located at the end of JBOSS_HOME? It needs to be a JBoss AS 5.x -- preferably 5.1.0.

  • 2. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    Andrew Dinn Master

    Ok, my backgrouond builds of 4_6_1_GA_CP05 against EAP 5.0 and JBossAS 5.1.0.CR1 have just finished and both have failed because the logger API is incompatible. The logging API for AS is being tweaked at the moment and Jonathan has been updating TS accordingly. I think this indicates that 4_6_1_GA_CP05 has been built against an unreleased version of JBossAS 5.1 which may still only be in trunk -- in other words don't use it yet. Perhaps Jonathan might know the specifics.

  • 3. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    Jonathan Halliday Master

    The CP lines are maintenance branches for the platform, not the project. CP05 is designed to build jts against branch JBPAPP_5_1, which it does just fine. You should not need to be building it at all (there is a perfectly good binary already) and if you do, you should be building the jts as that is what the sever uses and replacing it with a jta build will cause you headaches.

  • 4. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    testrot Newbie

    Hello Andrew, hello Jonathan,

     

    first of all sorry for posting to the wrong forum. If I have another question I will use the user forum.

     

    I wanted to build JBOSSTS_4_6_1_GA_CP05 because right now I am using JBoss Application Server 5.1.0.GA with the included version of JBossTS (I think it is 4.6.1.GA) and I'm trying to get failure recovery to work with MS SQL Server 2005/2008 for about 2 weeks now and still get this nasty warnings:

     

    2010-07-01 18:07:28,251 WARN [com.arjuna.ats.jta.logging.loggerI18N] (WorkerThread#0[10.3.4.122:2557]) [com.arjuna.ats.internal.jta.resources.arjunacore.commitxaerror] [com.arjuna.ats.internal.jta.resources.arjunacore.commitxaerror] XAResourceRecord.commit - xa error XAException.XAER_RMERR

     

    I guess the above warning is ok, because I intentionally shutdown the SQL Server right after the prepare and before the commit phase, to simulate a problematic DB shutdown.

     

    But the following warnings should not appear. Even worse the MS SQL database is not reachable anymore and marked as "suspect" if a recovery is not made after restarting SQL Server within 1-2 minutes.

     

    2010-07-01 18:07:35,626 WARN [com.arjuna.ats.jta.logging.loggerI18N] (Thread-19) [com.arjuna.ats.internal.jta.recovery.xarecovery1] Local XARecoveryModule.xaRecovery got XA exception javax.transaction.xa.XAException: Fehler bei der Funktion 'RECOVER:'. Status: '-3'. Fehler: '*** SQLJDBC_XA DTC_ERROR Context: xa_recover, state=1, StatusCode:-3 (0xFFFFFFFD) ***'., XAException.XAER_RMERR


    2010-07-01 18:07:55,672 WARN [com.arjuna.ats.jta.logging.loggerI18N] (Thread-19) [com.arjuna.ats.internal.jta.resources.arjunacore.norecoveryxa] [com.arjuna.ats.internal.jta.resources.arjunacore.norecoveryxa] Could not find new XAResource to use for recovering non-serializable XAResource < 131075, 25, 23, 494597485148525597585756101585299509998985598589749974851485255975857561015852995099989855985897101 >


    Yes, I configured the AppServerJDBCXARecovery module :-) :

     

         <property name="com.arjuna.ats.jta.recovery.XAResourceRecoveryJDBC" value= "com.arjuna.ats.internal.jbossatx.jta.AppServerJDBCXARecovery;jndiname=MY_DS,username=test,password=test"/>

     

    So I thought to myself this must be a bug because others use JBoss AS with failure recovery and wanted to apply the latest patches.

     

    Jonathan, you wrote, that the CP lines are maintenance branches for the platform, not the project and that there are binary builds available. I don't understand your statement. Do you mean the CP01-CP05 builds can't be used with JBoss AS 5.1.0.GA? Where are the binaries? I can not find them at the download section http://www.jboss.org/jbosstm/downloads.html.

     

    Regards,

    Martin

  • 5. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    Grant Sheppard Newbie

    I've got a similar problem using JBoss SOA 5.0.1.GA (which uses JBossTS 4.6.1.GA_CP03).

     

    If I let the transaction manager move a transaction to the 'prepare' stage and then stop SQL Server, restarting it results in a 'suspect' database. I am then forced to abort the transaction manually before restarting the database server again. I then (sometimes) get the error that you see: -

    16:08:03,777 WARN  [loggerI18N]  [com.arjuna.ats.internal.jta.recovery.xarecovery1] Local  XARecoveryModule.xaRecovery  got XA exception  javax.transaction.xa.XAException: The functio
    n RECOVER: has failed. The status is: -3. Error: "*** SQLJDBC_XA  DTC_ERROR Context: xa_recover, state=1, StatusCode:-3 (0xFFFFFFFD) ***",  XAException.XAER_RMERR

    I haven't been able to repeatably reproduce this error though - sometimes the recovery manager successfully 'recovers' the transaction that I manually killed and you see this in the log: -

    11:41:17,452 DEBUG [logger] Local XARecoveryModule.transactionInitiatedRecovery completed
    11:41:17,483 DEBUG [AppServerJDBCXARecovery] Created new XAConnection
    11:41:17,483 DEBUG [logger] xarecovery of  XAResourceID:45
    11:41:17,499 DEBUG [logger] Found 0 xids in doubt

    This to me suggests that the recovery manager successfully sent the 'recover' command to SQL Server, requesting any in doubt transactions and that the server responded with none (because I had already aborted the transaction).

  • 6. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    Andrew Dinn Master

    testrot wrote:

     

    Jonathan, you wrote, that the CP lines are maintenance branches for the platform, not the project and that there are binary builds available. I don't understand your statement. Do you mean the CP01-CP05 builds can't be used with JBoss AS 5.1.0.GA? Where are the binaries? I can not find them at the download section http://www.jboss.org/jbosstm/downloads.html.

     

    Specifically he stated that 4.6.1.CP05 cannot be built with JBossAS 5.1.0.GA. The latter is a community release of our app server (AS) which is built to work with a specific version of JBossTS -- you can see which one (4.6.1.GA) if you check the JBossTS version in the AS source component-matrix pom.xml. We don't guarantee that it will also work with later versions of TS -- even later CP (cumulative partch) versions -- because this is community code and you are expected, in fact positively encouraged, to tinker with it and patch things yourself. If you need a new version of TS to fix a bug in the one used by this community AS release then there are three options:

     

    1. you fix the bug and send us the patch for inclusion in a later release
    2. you raise a JIRA for us to fix and then retro-fit our patches to your TS source release
    3. you raise a JIRA and wait for a new community AS release to come out which includes a fix provided by us

     

    Depending on what else we are fixing and how much that changes related code you may not be abled to adopt path 2.

     

    The 4.6.1 branch happens to be the code we are using to build the EAP 5.1 product. That's one of the versions of JBoss AS we provide support for. Once a product release is out we work very hard to produce regular updates and rapid release of critical fixes and we strive to retain backward compatibility. So, although 4.6.1.CP05 no longer works with the community version it does work with the EAP 5.1 product code and later CP versions will continue to do so. If you want to use this product version of AS you can locate the relevant EAP code in our repo and build yourself an EAP binary release -- it's all open source so off you go. Clearly, we wll be more interested in getting this out the door and maintaining/developing it than helping you build, install  and run it but you can always come and ask for help here if you cannot work out how to fix things and raise JIRAs if something is broken. Alternatively, buy a support license and we will hand over binaries, sources, regular patches and lots of help to resolve any problems you have.

  • 7. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    testrot Newbie

    Thanks Andrew,

     

    I think I got the point now.

     

    Because I generally can't live with the known bugs included in the current community version (5.1.0.GA) and I don't expect a newer version of it any time soon, I have to switch to the supported EAP Version.

     

    Is this the right URL to get the sources for building the newest EAP 5.X version:

    http://anonsvn.jboss.org/repos/jbossas/tags/JBPAPP_5_0_1_GA/

     

    What is the license of the this EAP version. Is it still LGPL?

     

    Regards,

    Martin

  • 8. Re: Can't build JBOSSTS_4_6_1_GA_CP05
    Andrew Dinn Master

    testrot wrote:

     

    Because I generally can't live with the known bugs included in the current community version (5.1.0.GA) and I don't expect a newer version of it any time soon, I have to switch to the supported EAP Version.

    You are right not to expect a newer community release of AS 5.1.0. The community versions are now being based on AS 6.0, the latest being 6.0.0.M3. You could actually try that as it is fairly stable and is still on an upgarde path.

    testrot wrote:

     

    Is this the right URL to get the sources for building the newest EAP 5.X version:

    http://anonsvn.jboss.org/repos/jbossas/tags/JBPAPP_5_0_1_GA/

    If you look at pom.xml in component_matrix for that tag it uses 4.6.1.CP04. Keep looking :-)

     

    testrot wrote:

     

    What is the license of the this EAP version. Is it still LGPL?

    Yes. The code cannot change license just because we include it in a supported version. That's not how open source works.