2 Replies Latest reply: Jun 15, 2010 1:11 PM by Ales Justin RSS

[JBOSGI-342] Bundle resolution depends on install order

Thomas Diesler Master

Working on https://jira.jboss.org/jira/browse/JBOSGI-342, I see

 

2010-06-15 16:31:57,222 INFO  [org.jboss.osgi.framework.plugins.internal.FrameworkEventsPluginImpl] Bundle INSTALLED: Bundle{org.apache.felix.eventadmin-1.2.2}
2010-06-15 16:31:57,223 DEBUG [org.jboss.osgi.framework.bundle.OSGiBundleManager] Added: Bundle{org.apache.felix.eventadmin-1.2.2}
2010-06-15 16:31:57,224 DEBUG [org.jboss.classloading.spi.dependency.Domain] org.jboss.classloading.spi.dependency.Domain@6e72d873{OSGiClassLoaderDomain} add module OSGiModule org.apache.felix.eventadmin:1.2.2
2010-06-15 16:31:57,225 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 joining org.jboss.classloading.spi.dependency.ClassLoadingSpace@38650646
2010-06-15 16:31:57,271 DEBUG [org.jboss.osgi.framework.resolver.LoggerDelegate] WIRE: [Module[Bundle{org.apache.felix.eventadmin-1.2.2}]] package; (&(package=org.osgi.service.cm)(version>=1.2.0)(!(version>=2.0.0))) -> [Module[Bundle{osgi.cmpn-4.2.0.200908310645}]]
2010-06-15 16:31:57,271 DEBUG [org.jboss.osgi.framework.resolver.LoggerDelegate] WIRE: [Module[Bundle{org.apache.felix.eventadmin-1.2.2}]] package; (&(package=org.osgi.service.event)(version>=1.2.0)) -> [Module[Bundle{osgi.cmpn-4.2.0.200908310645}]]
2010-06-15 16:31:57,271 DEBUG [org.jboss.osgi.framework.resolver.LoggerDelegate] WIRE: [Module[Bundle{org.apache.felix.eventadmin-1.2.2}]] package; (&(package=org.osgi.service.metatype)(version>=1.1.0)(!(version>=2.0.0))) -> [Module[Bundle{osgi.cmpn-4.2.0.200908310645}]]
2010-06-15 16:31:57,273 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule osgi.cmpn:4.2.0.200908310645 resolving org.jboss.classloading.spi.dependency.ClassLoadingSpace@c4e21db
2010-06-15 16:31:57,274 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[info.dmtree;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[info.dmtree;version=1.0.1]}
2010-06-15 16:31:57,275 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[info.dmtree.notification;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[info.dmtree.notification;uses:=info.dmtree;version=1.0]}
2010-06-15 16:31:57,275 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[info.dmtree.notification.spi;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[info.dmtree.notification.spi;uses:=info.dmtree.notification;version=1.0]}
2010-06-15 16:31:57,276 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[info.dmtree.registry;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[info.dmtree.registry;uses:=org.osgi.framework,info.dmtree,info.dmtree.notification;version=1.0]}
2010-06-15 16:31:57,276 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[info.dmtree.security;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[info.dmtree.security;uses:=info.dmtree;version=1.0]}
2010-06-15 16:31:57,277 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[info.dmtree.spi;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[info.dmtree.spi;uses:=info.dmtree;version=1.0]}
2010-06-15 16:31:57,283 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.application;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.application;uses:=org.osgi.framework;version=1.0]}
2010-06-15 16:31:57,284 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.application;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.application;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,285 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.blueprint.container;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.blueprint.container;uses:=org.osgi.service.blueprint.reflect,org.osgi.framework;version=1.0]}
2010-06-15 16:31:57,286 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.blueprint.reflect;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.blueprint.reflect;version=1.0]}
2010-06-15 16:31:57,287 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;resolution:=optional;version=[1.3,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,288 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.component;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.component;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,290 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.deploymentadmin;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.deploymentadmin;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,291 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.deploymentadmin.spi;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.deploymentadmin.spi;uses:=org.osgi.service.deploymentadmin,org.osgi.framework;version=1.0.1]}
2010-06-15 16:31:57,292 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.device;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.device;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,293 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,295 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.http;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.http;uses:=javax.servlet.http,javax.servlet;version=1.2.1]}
2010-06-15 16:31:57,296 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.io;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.io;uses:=javax.microedition.io;version=1.0]}
2010-06-15 16:31:57,298 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;resolution:=optional;version=[1.3,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,299 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,301 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.monitor;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.monitor;version=1.0]}
2010-06-15 16:31:57,303 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.prefs;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.prefs;version=1.1.1]}
2010-06-15 16:31:57,305 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.provisioning;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.provisioning;version=1.2]}
2010-06-15 16:31:57,307 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.upnp;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.upnp;version=1.1]}
2010-06-15 16:31:57,309 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.useradmin;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.useradmin;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,312 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.service.wireadmin;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.wireadmin;uses:=org.osgi.framework;version=1.0]}
2010-06-15 16:31:57,314 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.util.cdma;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.util.cdma;uses:=org.osgi.framework,org.osgi.service.condpermadmin;version=1.0]}
2010-06-15 16:31:57,317 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.util.gsm;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.util.gsm;uses:=org.osgi.framework,org.osgi.service.condpermadmin;version=1.0.1]}
2010-06-15 16:31:57,319 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.util.measurement;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.util.measurement;version=1.0.1]}
2010-06-15 16:31:57,322 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.util.mobile;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.util.mobile;uses:=org.osgi.framework,org.osgi.service.condpermadmin;version=1.0]}
2010-06-15 16:31:57,324 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.util.position;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.util.position;uses:=org.osgi.util.measurement;version=1.0.1]}
2010-06-15 16:31:57,327 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.util.tracker;resolution:=optional;version=[1.4,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.util.tracker;uses:=org.osgi.framework;version=1.4]}
2010-06-15 16:31:57,330 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[org.osgi.util.xml;resolution:=optional;version=[1.0,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.util.xml;uses:=javax.xml.parsers,org.osgi.framework;version=1.0.1]}
2010-06-15 16:31:57,331 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{osgi.cmpn-4.2.0.200908310645[*]} resolves against OSGiPackageCapability{org.apache.felix.eventadmin-1.2.2[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,331 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 resolving org.jboss.classloading.spi.dependency.ClassLoadingSpace@38650646
2010-06-15 16:31:57,333 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.cm;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,334 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 joining org.jboss.classloading.spi.dependency.ClassLoadingSpace@c4e21db
2010-06-15 16:31:57,334 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 unjoining org.jboss.classloading.spi.dependency.ClassLoadingSpace@38650646
2010-06-15 16:31:57,334 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 unresolving org.jboss.classloading.spi.dependency.ClassLoadingSpace@38650646
2010-06-15 16:31:57,334 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 resolving org.jboss.classloading.spi.dependency.ClassLoadingSpace@c4e21db
2010-06-15 16:31:57,335 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.cm;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,336 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.event;version=1.2]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,338 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.metatype;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,339 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.log]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,340 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.event;version=1.2]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,341 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.metatype;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,342 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.log]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,343 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.metatype;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,343 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 resolving org.jboss.classloading.spi.dependency.ClassLoadingSpace@c4e21db
2010-06-15 16:31:57,344 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.cm;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,345 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.event;version=1.2]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,346 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.metatype;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,347 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.log]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,348 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.event;version=1.2]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,348 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 resolving org.jboss.classloading.spi.dependency.ClassLoadingSpace@c4e21db
2010-06-15 16:31:57,349 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.cm;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,350 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.event;version=1.2]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,351 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.metatype;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,352 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.log]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,352 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.cm;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,353 TRACE [org.jboss.classloading.spi.dependency.ClassLoadingSpace] OSGiModule org.apache.felix.eventadmin:1.2.2 resolving org.jboss.classloading.spi.dependency.ClassLoadingSpace@c4e21db
2010-06-15 16:31:57,353 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.cm;resolution:=optional;version=[1.2,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.cm;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,354 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.event;version=1.2]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.event;uses:=org.osgi.framework;version=1.2]}
2010-06-15 16:31:57,355 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.metatype;resolution:=optional;version=[1.1,2)]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.metatype;uses:=org.osgi.framework;version=1.1]}
2010-06-15 16:31:57,356 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.log]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;uses:=org.osgi.framework;version=1.3]}
2010-06-15 16:31:57,356 TRACE [org.jboss.classloading.spi.dependency.Domain] Requirement OSGiPackageRequirement{org.apache.felix.eventadmin-1.2.2[org.osgi.service.log]} resolves against OSGiPackageCapability{osgi.cmpn-4.2.0.200908310645[org.osgi.service.log;uses:=org.osgi.framework;version=1.3]}

 

The compendium gets installed before the eventadmin bundle. The resolver does its work and establishes three wires. All optional imports from the compendium get resolved . The DynamicImport-Package: * from the compendium gets resolved against the first capability from eventadmin.

 

What follows is a near endless loop of attempts to resolve the eventadmin class space.

  • 1. Re: [JBOSGI-342] Bundle resolution depends on install order
    Thomas Diesler Master

    [5:27:55 PM] Thomas Diesler: I'm not so sure that RDI should be created for DynImps before the module reaches ClassLoader stage
    [5:28:47 PM] Thomas Diesler: DynImps are irrelevant in the decission of whether a module can resolve
    [5:30:25 PM] Thomas Diesler: When a class gets loaded the dynimp should kick in as last resort
    [5:30:46 PM] Ales Justin: makes sense

     

    A possible solution might be to always return null from Domain.resolveModule(Module module, Requirement requirement) for DynImps before we reach ClassLoader stage. After that a WildcardDelegateLoader gets created and added for every DynImp. Conceptionally, a module would resolve without taking DynImps into consideration, but once it is resolved the WildcardDelegateLoader would be available.

     

    If this is the way to go forward, I'd appreciate a few hints on how to do this.

  • 2. Re: [JBOSGI-342] Bundle resolution depends on install order
    Ales Justin Master
    If this is the way to go forward, I'd appreciate a few hints on how to do this.

    Actually I don't see why initial DI resolution for wildcards would pose a problem.

    What you get out of it is WildcardDelegateLoader, which is then what really knows how to handle "any" resource lookup.

    Meaning the initial resolution has no effect to whome you wired to.

     

    Or you're saying that plain dynamic-import is the problem if it gets resolved?

    But this is actually the same as if it were resolved later on in the new WDL mechanism.

     

    Weak or too broad requirements lead to bad resolving. ;-)