4 Replies Latest reply: Jan 4, 2011 3:26 AM by Nabil Benothman RSS

Need help on GWT's gadget deployment on GateIn

Esslem GHODBANE Newbie

Hello,

 

I'm traying to make a Hello-World gadget and to deploy it under GateIn.

I followed some tutorials which begin by making a standard GWT and then convert  it into a gadget.

But I ignore what should I make as additional configuration to find this gadget in the auto-imported gadget box.

I'd like that you suggest me a tutorial that help to make a gadget ant deploy it on GateIn.

 

I'll be grateful

Esslem,

  • 1. Re: Need help on GWT's gadget deployment on GateIn
    Mike Brock Master

    I must confess to not having any direct experience with GateIn.  Although we've had preliminary talks within JBoss about doing integration with GateIn and Errai.

     

    Has the GateIn team been any help?

  • 2. Re: Need help on GWT's gadget deployment on GateIn
    Thomas Heute Master

    You can build GWT gadgets to embed in GateIn:

    http://community.jboss.org/wiki/GadgetsandaccessingPortalServices

     

    I guess you are interested by the last line. For gadgets you need to individually add them.

  • 3. Re: Need help on GWT's gadget deployment on GateIn
    Esslem GHODBANE Newbie


    Thank you both
    I have deployed the gadget in gateIn without problem but I have found that it generates an exception like this :

    An error occured when trying to get the username<html>[...]
    So I've accessed the entry point of the gadget and I have disabled the main module and this has shown the hello world wanted, but even after following the documentation and the configuration of SSO, the launch of the gwt-widget example does not succeeded, and it generates exceptions.

    So, this sample requires more configuration ?

  • 4. Re: Need help on GWT's gadget deployment on GateIn
    Nabil Benothman Newbie

    Hi,

    I had the same problem when trying to deploy the gadget, I modified the gadget but I got always an error (see below) when calling asynchronously some call on server. Is there any further configuration that I missed? How to use asynchronous call with gadgets ?

     

    thanks in advance.

     

     

     

    An error occurs while retrieving root nodes : 405 <html><head><title>JBoss Web/2.1.3.GA - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 405 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>The specified HTTP method is not allowed for the requested resource ().</u></p><HR size="1" noshade="noshade"><h3>JBoss Web/2.1.3.GA</h3></body></html>