8 Replies Latest reply: Feb 13, 2009 11:33 AM by Peter Johnson RSS

JDK 1.6.0_10/JBoss4.2.0.GA/JBossWS 2.0.0 - setProperty must

Larry Compton Newbie

I'm having trouble getting JBossWS/JBossAS working in JDK 1.6. I'm aware of the existing bug report....

https://jira.jboss.org/jira/browse/JBWS-1439

I ran the JBossWS ant script using JDK 1.6 and verified that the following JARs were copied into $JBOSS_HOME/lib/endorsed....
jaxb-api.jar
jboss-jaxrpc.jar
jboss-jaxws.jar
jboss-saaj.jar

However, I still get exceptions of this sort....
javax.xml.ws.WebServiceException: java.lang.UnsupportedOperationException: setProperty must be overridden by all subclasses of SOAPMessage
at org.jboss.ws.core.jaxws.client.ClientImpl.handleRemoteException(ClientImpl.java:317)
at org.jboss.ws.core.jaxws.client.ClientImpl.invoke(ClientImpl.java:255)
at org.jboss.ws.core.jaxws.client.ClientProxy.invoke(ClientProxy.java:164)
at org.jboss.ws.core.jaxws.client.ClientProxy.invoke(ClientProxy.java:150)

Configuration:
JDK 1.6.0_10
JBoss AS 4.2.0.GA
JBossWS 2.0.0
Ubuntu 8.10

Unfortunately, upgrading to later versions isn't an option.

Larry