10 Replies Latest reply: Jul 10, 2012 8:59 PM by Michael Daleiden RSS

Forge not working from either command line or JBDS 5 GA

Michael Daleiden Newbie

I am struggling to get Forge to work on my Win7/64-bit PC. I can start up Forge (or the Forge Console in JBDS) and create a new project, but when I then try to work with facets, the 'project list-facets' command returns rather cryptic results:

 

[no project] workspace $ cd \openshift-git

[no project] openshift-git $ new-project

? [named=The name of the new project (of type java.lang.String)]: blah

? Use [C:\/openshift-git/blah] as project directory? [Y/n] Y

***SUCCESS*** Created project [blah] in new working directory [C:\/openshift-git/blah]

Wrote C:\/openshift-git/blah

Wrote C:\/openshift-git/blah/pom.xml

Wrote C:\/openshift-git/blah/src/main/java

Wrote C:\/openshift-git/blah/src/test/java

Wrote C:\/openshift-git/blah/src/main/resources

Wrote C:\/openshift-git/blah/src/test/resources

Wrote C:\/openshift-git/blah/src/main/java/com/example/blah

Wrote C:\/openshift-git/blah/src/main/resources/META-INF/forge.xml

[blah] blah $ project list-facets

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

Class

 

Any ideas as to what is going on here?

 

Forge 1.0.5 final

Win 7/64-bit (32-bit JDK, though)

FORGE_HOME is set to point to the 'forge-distribution-1.0.5.Final' directory that resulted from extracting the Forge 1.0.5 zip file to my local hard drive.