1 2 Previous Next 18 Replies Latest reply: Apr 26, 2012 11:00 PM by Ted Jones Go to original post RSS
  • 15. Re: Error at deploy Webservice Rest.
    Ted Jones Apprentice

    Luiz,

     

    The generated war you linked me to only had source files in it. This means, for whatever reason, the compilation did not complete. So it will not deploy successfully until the compliation step is successful.

     

    Since I was able to generate the war successfully from the MPS you posted (I uploaded it here: http://www.4shared.com/file/Q2pBf39C/VDB.html) using Teiid Designer 7.6 and JDK 1.7.0_03 X64, it indicates "something" around your environment configuration.

     

    Here is my eclipse.ini:

     

    -startup

    plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

    --launcher.library

    plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505

    -product

    org.eclipse.epp.package.jee.product

    --launcher.defaultAction

    openFile

    -showsplash

    org.eclipse.platform

    --launcher.XXMaxPermSize

    256m

    --launcher.defaultAction

    openFile

    -vm

    /home/tejones/apps/java/jdk1.7.0_03/bin

    -vmargs

    -Dosgi.requiredJavaVersion=1.5

    -XX:MaxPermSize=256m

    -Xms40m

    -Xmx512m

     

    Make sure your JDK is explicitly set as shown above.

     

    Thanks,

    Ted

  • 16. Re: Error at deploy Webservice Rest.
    Luiz Cortinhas Newbie

    Ted,

         My eclipse.ini, look after -vm line:

           -startup

              plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

           -product

              org.eclipse.epp.package.jee.product

           --launcher.defaultAction

               openFile

           -showsplash

               org.eclipse.platform

           --launcher.XXMaxPermSize

               256m

           --launcher.defaultAction

               openFile

           -vm

               C:\Program Files (x86)\Java\jdk1.7.0_03\bin\

            -vmargs

              -Dosgi.requiredJavaVersion=1.5

            -XX:MaxPermSize=256m

            -Xms40m

            -Xmx512m

     

    My JDK is configurated

     

    Thanks, Luiz Cortinhas.

  • 17. Re: Error at deploy Webservice Rest.
    Ted Jones Apprentice

    Luiz,

     

    The only other difference then is our Operating Systems (Windows vs Linux). I will try to test on Windows and see if I can duplicate the compilation issue. In the meantime, please check your Designer log file to see if there are any errors being logged during the war generation process.

     

    Thanks,

    Ted

  • 18. Re: Error at deploy Webservice Rest.
    Ted Jones Apprentice

    Luiz,

     

    The following error was uncovered attempting to duplicate your issue: https://issues.jboss.org/browse/TEIIDDES-1330

     

    This is likely the underlying cause. You can either use another OS to run Designer on or use 7.5. We will have this resolved for 7.7.1.

     

    Thanks,

    Ted

1 2 Previous Next