1 Reply Latest reply: Apr 18, 2012 9:55 AM by Peter Johnson RSS

using RestEasy

Steve Jagels Newbie

I am trying to do a simple RestEasy application.  I downloaded the latest RestEasy jar files.  I created the java application.  When I run it I get a 404 error.  When jboss starts up, I see an error:

 

java.lang.UnsupportedClassVersionError: Bad version number in .class file

 

Based on what people have said on other websites, apparently I'm running an earlier version of java than what the RestEasy jar files were compiled on.  So what should I do?

 

I am running:

 

Eclipse 4.3.0.GA_CP03

JBoss 4.3.0.GA_CP03

JDK 1.5.0.17