1 2 3 4 5 Previous Next 62 Replies Latest reply: May 3, 2012 8:55 AM by Stelian Niculescu Go to original post RSS
  • 60. Re: Arquillian testing with JBoss
    Patrick T Newbie

    Finally I found the root of the problem. Installing the application on jboss also altered my server.xml, adding a security certificate to the https connection. After removing this entry, the test ran perfectly. But the problem is, that this certificate is intended to be used. Is there a possibility to add this to the test somehow?

     

    Thx,

     

    Patrick

     

    edit: Damn. Only a modified test worked. In this modified test, the class I tested successfully was not deployed beforehand but within the test package itself. When I try to test a class, thats already installed on the server, I get a ClassNotFoundException.

     

    edit2: This seems to have to do with the installed application too,  since everthing works fine on a clean server where a single bean containing a single method is installed. I'm trying to get some more info tomorrow.

  • 61. Re: Arquillian testing with JBoss
    Patrick T Newbie

    Hi again. I was able to fix all problems mentioned in the edits. So the only problem remaining right now is the SSL certificate. Is it possible to change the port the testrunnerservlet uses to the http-port somehow?

     

    Thx,

     

    Patrick

  • 62. Re: Arquillian testing with JBoss
    Stelian Niculescu Newbie

    Hello,

     

    I have the exact same problem as you had in this post (the one with java.net.SocketException: Unexpected end of file from server ). Can you elaborate a bit on what you did wrong? I've been struggling with this for over a day.

     

    Stelian

1 2 3 4 5 Previous Next