9 Replies Latest reply: Feb 27, 2012 7:46 AM by David Robison RSS

Error [MEM: MEM: Can't update or insert host alias: {4}]

Derric Moses Newbie

I am having a problem with mod_cluster.  We are running jboss 6.0.0.Final, mod_cluster 1.1, and apache 2.2.3.  We have several small webapps that run in jboss under 10 different domain names.  For each of these domains we have a production, stage and dev alias in the host configuration in the applications jboss-web.xml as well as the jboss servers' server.xml.  We constantly get this error message in the jboss server.log as well in the apache's log for mod_cluster.

 

2011-01-07 16:20:00,993 ERROR [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] (ContainerBackgroundProcessor[StandardEngine[jboss

.web]]) Error [MEM: MEM: Can't update or insert host alias: {4}] sending command ENABLE-APP to proxy apachedev/10.77.77.133:80, con

figuration will be reset

 

Its not consistant on what number of web applications are deployed when it happens or even which web applications. 

 

 

jboss server.xml snippet

(each domain has a host entry in the server.xml)

 

         <Host name="www.server1.com" autoDeploy="false" deployOnStartup="true">

                <Alias>dev.server1.com</Alias>

                <Alias>stage.server1.com</Alias>

                <Valve className="org.apache.catalina.valves.AccessLogValve" prefix="www.server1.com" suffix=".log" pattern="common" directory="${jboss.server.home.dir}/log"/>

         </Host>

 

         <Host name="www.server2.com" autoDeploy="false" deployOnStartup="true">

                <Alias>dev.server2.com</Alias>

                <Alias>stage.server2.com</Alias>

                <Valve className="org.apache.catalina.valves.AccessLogValve" prefix="www.server2.com" suffix=".log" pattern="common" directory="${jboss.server.home.dir}/log"/>

         </Host>

 

         <Host name="www.server3.com" autoDeploy="false" deployOnStartup="true">

                <Alias>dev.server3.com</Alias>

                <Alias>stage.server3.com</Alias>

                <Valve className="org.apache.catalina.valves.AccessLogValve" prefix="www.server3.com" suffix=".log" pattern="common" directory="${jboss.server.home.dir}/log"/>

         </Host>

 

 

apache httpd.conf snippet

(each domain has a virtual host entry in the httpd.conf)

 

#

# Virtual Host for www.server1.com

#

#

<VirtualHost *:80>

  ServerName www.server1.com

  RewriteEngine On

  RewriteCond %{HTTPS} off

  RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

</VirtualHost>

<VirtualHost 10.77.77.133:443>

ServerName www.server1.com

<Directory />

   Order deny,allow

   Allow from all

</Directory>

 

 

SSLEngine on

SSLCertificateFile    /etc/httpd/certs/test.crt

SSLCertificateKeyFile /etc/httpd/certs/test.key

SSLCertificateChainFile /etc/httpd/certs/testch.crt

 

 

Maxhost 25

UseAlias yes

Maxnode 25

KeepAliveTimeout 60

MaxKeepAliveRequests 0

ProxyPass / balancer://devcluster/ stickysession=JSESSIONID|jsessionid nofailover=On

ErrorLog logs/server1-error_log

CustomLog logs/server1-access_log common

</VirtualHost>

 

 

 

 

this is part of the httpd log from the cluster-manager

 

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "CONFIG / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:04 -0500] "ENABLE-APP / HTTP/1.0" 500 634

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "INFO / HTTP/1.0" 200 1901

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "CONFIG / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "ENABLE-APP / HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "REMOVE-APP /* HTTP/1.0" 200 -

10.77.77.134 - - [07/Jan/2011:16:41:14 -0500] "CONFIG / HTTP/1.0" 200 -

 

 

Has anybody seen this error or notice anything obviously wrong with our configuration.

 

2011-01-07 16:20:00,993 ERROR [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] (ContainerBackgroundProcessor[StandardEngine[jboss

.web]]) Error [MEM: MEM: Can't update or insert host alias: {4}] sending command ENABLE-APP to proxy apachedev/10.77.77.133:80, con

figuration will be reset