6 Replies Latest reply: Feb 26, 2012 8:08 AM by Johan Vermeij RSS

mod_cluster 1.2.Final + AS 7.1 Final -problem ?

Maciej Lad Newbie

Hi,

I have some problems with work with mod_cluster.

 

1) When I started jboss x2 and use application replication_test was ok.

2) When I using apps and click DISABLE application in mod_cluster status page, using apps not ended... ( anything in jboss log )

3) When I re-using  ( create new sessions ) - application is not found.

4) When I click ENABLE after a disable applications not started/not served by mod_cluster.

5) When I killed jboss applications not switch to next jboss ( I think this is problem with stickly sessions to set false - not probe yet )

6) How to configure statistics for: Load: 1 - I have allways value 1 - could you give step by step.

7) on "/replication-test, Status: ENABLED Request: 0 Disable" in pool Request:0 I have always value 0, why ? if I used this apps on this jboss ?

 

pls help me with this..problems...

 

 

 

My configurations:

 

Machine Box 1:

2x AS 7.1Final on diferent IP.

( x.x.192.3 and x.x.192.4 )

Started in standalone-ha mode.

 

Machine Box 2:

Server version: Apache/2.2.15 (Unix) with modcluster 1.2.0 Final

 

Block/not work: multicast beetween box1 and box2 ( jgroups test not work ) meybe this is a problem with refresh statistics on status page ?? )

 

Configuration:

 

LoadModule slotmem_module modules/mod_slotmem.so
LoadModule manager_module modules/mod_manager.so
LoadModule proxy_cluster_module modules/mod_proxy_cluster.so
LoadModule advertise_module modules/mod_advertise.so

<VirtualHost 172.17.126.1:80>

        <Directory />
                Order deny,allow
                Allow from all
        </Directory>

        KeepAliveTimeout 60
        MaxKeepAliveRequests 0

       AdvertiseFrequency 5

       <Location /mod_cluster-manager>
           SetHandler mod_cluster-manager

           Order deny,allow
           Deny from all
           Allow from all
       </Location>

  ErrorLog logs/cluster-error.log
  CustomLog logs/cluster-access.log combined
  LogLevel debug

  EnableMCPMReceive
  AllowDisplay on

</VirtualHost>

 

 

Jboss to modcluster is in AJP mode.

 

mod_cluster status page:

 

 

mod_cluster/1.2.0.Final

start of "httpd.conf" configuration

mod_proxy_cluster.c: OK

mod_sharedmem.c: OK

Protocol supported: http AJP

mod_advertise.c: OK

Server: apache-cluster

Server: apache-cluster VirtualHost: x.x.126.1:80 Advertising on Group 224.0.1.105 Port 23364 for http://x.x.126.1:80 every 5 seconds

end of "httpd.conf" configuration

 

Auto Refresh show DUMP output show INFO output 

Node ca923d2f-614f-3ec1-ab39-b7300c8d727e (ajp://x.x.192.3:8009):

Enable Contexts Disable Contexts

Balancer: mycluster,LBGroup: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 1,Ttl: 60000000,Status: OK,Elected: 74,Read: 16567,Transferred: 0,Connected: 0,Load: 1 

Virtual Host 1:

Contexts:

/, Status: ENABLED Request: 0 Disable  /replication-test, Status: ENABLED Request: 0 Disable  
/replication-test, Status: ENABLED Request: 0 Disable

Aliases:

default-host  localhost  example.com  

Node 23949d3c-889c-34e2-839e-eef510714a63 (ajp://x.x.192.4:8009):

Enable Contexts Disable Contexts

Balancer: mycluster,LBGroup: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 1,Ttl: 60000000,Status: OK,Elected: 0,Read: 0,Transferred: 0,Connected: 0,Load: 1 

Virtual Host 1:

Contexts:

/, Status: ENABLED Request: 0 Disable  

Aliases:

default-host  localhost  example.com