1 Reply Latest reply: Feb 8, 2012 3:16 PM by Michael Evans RSS

Error creating a teiid instance

Kailash nath Newbie

I had followed the following steps and completed it.

Create Teiid server Instance

 

  1.   Right-click in Teiid view and select “New Teiid Instance” 
  2. Provide valid Admin URL information (Default URL for Teiid is "mms://localhost:31443")

    • Specify Host (default = localhost) 
    • Specify Port Number (default = 31443) 
    • Specify User Name (default = "admin") 
    • Specify Password (default = "admin") 
    • This connection will be used by Designer to Add/Remove data-sources required for setting up valid VDB's and for deploy and undeploy your VDB's you wish to test. 
  3.   Provide valid JDBC URL information (Default URL for Teiid is "mms://localhost:31000") 
    • Specify Host (default = localhost) 
    • Specify Port Number (default = 31000) 
    • Specify User Name (default = "user") 
    • Specify Password (default = "user") 
    • This connection info will be used to set up JDBC connections to perform JDBC data queries to VDB's deployed on your Teiid server instance.
  4.   Hit FINISH 
  5. Initial Teiid View should contain your new Teiid server instance.

    • The Teiid view default contents will include any VDB's deployed to this server instance and any of your specific “workspace” Data Sources.

    • Data Sources are the  “JCA-compatible Connection Factory” xml configuration  components required for Teiid to create the necessary connections to query data at run-time.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

I installed teiid 7.4. I get an errow which sas connection refused. I have been following the tutorials given in http://community.jboss.org/wiki/TeiidDesigner74QuickStartGuide. So give me a solution in it.

  • 1. Re: Error creating a teiid instance
    Michael Evans Newbie

    I had the same issue after installing 7.6 and the designer.  The root cause was that the admin connection was attempting to use SSL and failing, but there was no indication anywhere of that.  To solve the problem, setup SSL or disable it.  You can disable SSL for admin by editing teiid-jboss-beans.xml and changing the AdminSslConfiguration bean config.  By default, mode is enabled.  Change it to disabled per the comments.