3 Replies Latest reply: Jan 8, 2012 5:20 PM by Miguel Escaja RSS

    Build JBoss 6.0.0-Final packaged with GateIn for PortletBridge 3.0.0-Beta1

    Miguel Escaja Newbie



      I´m having some issues setting up the JBoss Portlet Bridge 3.0.0-SNAPSHOT.


      First of all, in the anouncement :3.0.0.Beta1 Released! JSF2 and/or RichFaces 4!!!!  (http://www.jboss.org/portletbridge), you can find the note below


      "*Note - You must build GateIn from trunk to run on JBoss AS6. Find the maven command in the README.txt."


      So I followed the instructions in the The README.txt file. In a nut shell this is what I did


      svn co http://anonsvn.jboss.org/repos/gatein/portal/trunk/

      mvn clean install -DskipTests -Ppkg-jbossas6 -Dexo.projects.directory.dependencies=D:\GateIn-3.2.0-Trunk-jbossas6\trunk\packaging\servers


      then I started up JBoss 6.0.0 Final with GateIn Packaged and finally test




      The portal opens up fine and GateIn seems to work ok.


      The question is relating to the shared libraries location. In the README.txt it´s mentioned the below


      "shared libraries are placed into $JBOSS_HOME/server/default/lib instead of $JBOSS_HOME/server/default/deploy/gatein.ear/lib"


      However when I look into D:\GateIn-3.2.0-Trunk-jbossas6\trunk\packaging\jboss-as6\pkg\target\jboss\server\default\lib none of the shared libraries are there.


      It´s also mentioned in the README.txt that


      "gatein-sample-portal.ear, gatein-sample-extension.ear, and gatein-sample-skin.war are not included (they will be once the deployment descriptors are fixed)"


      and when I look into D:\GateIn-3.2.0-Trunk-jbossas6\trunk\packaging\jboss-as6\pkg\target\jboss\server\default\deploy I can find all three, gatein-sample-portal.ear, gatein-sample-extension.ear, and gatein-sample-skin.war deployed already.


      I´d like to understand why after following what´s in the README.txt I don´t seem to end up having JBoss packaged with GaitIn in the exact same way as described in the REDME.txt


      I must have done something wrong but I cannot figure out what.


      I´ve got to sort out this issue first (get JBoss with GateIn packaged from the trunk as described in the anouncement) before I can do something useful with the Portlet Bridge 3.0.0-SNAPSHOT.