4 Replies Latest reply: Oct 19, 2011 2:23 PM by stab RSS

    Deploying web-app using Errai, need help

    stab Newbie



      Managed to make a small chat-app using Errai.

      It runs nicely in hosted mode but when I try to deploy it to JBoss AS 7 I can't enable it.


      I thought it would be enough to install JBoss AS 7 and deploy using the Web Management interface

      without using JBoss together with Apache.

      Is this correct?


      When I didn't succeed to deploy my little chat-app I tried to deploy the cdi-quickstart instead doing the following:

      - mvn gwt:run   to test it in hosted mode, worked nicely

      - mvn package to create war

      - copied to war-file to my webserver

      - used Web Management interface to: add content, choose cdi-quickstart-1.3.0.CR1.war and enable


      Enabling resulted in error-message:


        Wed Oct 19 14:19:57 GMT+200 2011

      Unknown error


      Unexpected HTTP response: 500




          "address" => [("deployment" => "cdi-quickstart-1.3.0.CR1.war")],

          "operation" => "deploy"





      Internal Server Error


          "outcome" => "failed",

          "failure-description" => {"Services with missing/unavailable dependencies" => ["jboss.naming.context.java.module.\"cdi-quickstart-1.3.0.CR1\".\"cdi-quickstart-1.3.0.CR1\".env.ErraiService missing [ jboss.naming.context.java.jboss.resources.ErraiService ]"]},

          "rolled-back" => true



      Shouldn't the pom.xml tke care of all dependencies?