10 Replies Latest reply: Sep 1, 2011 4:39 PM by Paul Ferraro RSS

ROOT ignored in excludedContexts

larstobi Newbie

System info:

 

JBoss: jbossas-5.1.1-16.ep5.el5   (From RHEL5 RHN-channel "jbappplatform-5-x86_64-server-5-rpm")

mod_cluster: mod_cluster-1.1.3.Final-bin.zip

mod_cluster-native: mod_cluster-native-1.1.3-1.x86_64.rpm (compiled for httpd-2.2.17-11.1.ep5.el5)

 

JAVA_OPTS+=" -Djboss.mod_cluster.excludedContexts=ROOT,admin-console,invoker,jbossws,jmx-console,juddi,web-console"

 

 

Even though I add ROOT to excludedContexts as specified in the docs, the / context path still registers with Apache.

 

Node: [1],Name: 3e4aaeca-e3a0-3f3e-a017-8bbf1e995154,Balancer: mycluster,LBGroup: ,Host: xxx.xxx.xxx.203,Port: 8009,Type: ajp,Flushpackets: Off,Flushwait: 10,Ping: 10,Smax: 1,Ttl: 60,Elected: 0,Read: 0,Transfered: 0,Connected: 0,Load: 1
Vhost: [1:1:1], Alias: localhost
Context: [1:1:1], Context: /, Status: ENABLED
Context: [1:1:3], Context: /solr, Status: ENABLED

 

 

/etc/httpd/conf.d/cluster.conf:

 

Listen 7777
<VirtualHost *:7777>
  <Directory />
     Order deny,allow
     Allow from all
  </Directory>

  CreateBalancers 2
  KeepAliveTimeout 60
  MaxKeepAliveRequests 0
  ServerAdvertise Off
  AllowDisplay On

  <Location /mod_cluster_manager>
    SetHandler mod_cluster-manager
    Order deny,allow
    Allow from all
  </Location>
</VirtualHost>

 

 

 

What else can I do to make JBoss not register the / context?