8 Replies Latest reply: Aug 25, 2011 2:15 PM by michielt RSS

New AS 7.0.1 won't start - Caused by: java.lang.ClassNotFoundException: __redirected.__XMLInputFactory

michielt Newbie

Beginners warning;    Apologies in advance if I'm missing something stupid.

 

AIX 6.1 - Java 1.6

 

Trying to start AS 7.0.1, I get the following:

 

% ./standalone.sh

=========================================================================

 

  JBoss Bootstrap Environment

 

  JBOSS_HOME: /home/michiel/jboss-as-7.0.1.Final

 

  JAVA: /home/michiel/ibm-java-ppc-60/bin/java

 

  JAVA_OPTS: -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman

 

=========================================================================

 

03:48:24,981 INFO  [org.jboss.modules] JBoss Modules version 1.0.1.GA

03:48:26,193 INFO  [org.jboss.msc] JBoss MSC version 1.0.0.GA

03:48:26,443 INFO  [org.jboss.as] JBoss AS 7.0.1.Final "Zap" starting

03:48:28,142 ERROR [stderr] Exception in thread "Controller Boot Thread" javax.xml.stream.FactoryConfigurationError: Provider __redirected.__XMLInputFactory not found

03:48:28,142 ERROR [stderr]     at javax.xml.stream.XMLInputFactory.newInstance(Unknown Source)

03:48:28,143 ERROR [stderr]     at org.jboss.as.server.deployment.module.DeploymentStructureDescriptorParser.<clinit>(DeploymentStructureDescriptorParser.java:150)

03:48:28,151 ERROR [stderr]     at java.lang.J9VMInternals.initializeImpl(Native Method)

03:48:28,152 ERROR [stderr]     at java.lang.J9VMInternals.initialize(J9VMInternals.java:200)

03:48:28,152 ERROR [stderr]     at org.jboss.as.server.ServerService.boot(ServerService.java:167)

03:48:28,153 ERROR [stderr]     at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:83)

03:48:28,160 ERROR [stderr]     at java.lang.Thread.run(Thread.java:736)

03:48:28,161 ERROR [stderr] Caused by: java.lang.ClassNotFoundException: __redirected.__XMLInputFactory

03:48:28,162 ERROR [stderr]     at java.lang.Class.forName(Class.java:139)

03:48:28,163 ERROR [stderr]     at javax.xml.stream.FactoryFinder.newInstance(Unknown Source)

03:48:28,171 ERROR [stderr]     at javax.xml.stream.FactoryFinder.find(Unknown Source)

03:48:28,171 ERROR [stderr]     at javax.xml.stream.FactoryFinder.find(Unknown Source)

03:48:28,172 ERROR [stderr]     ... 7 more

 

% java -version

java version "1.6.0"

Java(TM) SE Runtime Environment (build pap3260sr9fp2-20110627_03(SR9 FP2))

IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc-32 jvmap3260sr9-20110624_8552      6 (JIT enabled, AOT enabled)

J9VM - 20110624_085526

JIT  - r9_20101028_17488ifx17

GC   - 20101027_AA)

JCL  - 20110530_01

 

I basically have no idea where to start looking. Internet search didn't give me any result.

This is installed straight out of the box, no configuration done. Any ideas?