6 Replies Latest reply: Jun 14, 2011 12:11 PM by Christian Sadilek RSS

GWT 2.2 and Errai 1.2.2 Final

Ravi Nori Newbie

I am trying to upgrade to GWT 2.2 and am getting the following errors. Is Errai compatiple with GWT 2.2?

 

java.lang.IncompatibleClassChangeError: Found interface com.google.gwt.core.ext.typeinfo.JClassType, but class was expected

        at org.jboss.errai.bus.rebind.ExtensionProxyGenerator.generate(ExtensionProxyGenerator.java:58)

        at com.google.gwt.core.ext.GeneratorExtWrapper.generate(GeneratorExtWrapper.java:48)

        at com.google.gwt.core.ext.GeneratorExtWrapper.generateIncrementally(GeneratorExtWrapper.java:60)

        at com.google.gwt.dev.javac.StandardGeneratorContext.runGeneratorIncrementally(StandardGeneratorContext.java:662)

        at com.google.gwt.dev.cfg.RuleGenerateWith.realize(RuleGenerateWith.java:41)

        at com.google.gwt.dev.shell.StandardRebindOracle$Rebinder.rebind(StandardRebindOracle.java:74)

 

I got similar erros with other libraries and downloaded the ones compiled with GWT 2.2 and the error s are gone. Where can I find Errai compiled for GWT 2.2.

 

Thanks