1 Reply Latest reply: May 5, 2011 2:41 PM by Paul Dwinnell RSS

JBoss 4.2.2GA Error with RMI: Accept timed out

Camilo Cuesta Newbie

Hi experts,

 

I'm getting this misterious error when I run JBoss 4.2.2GA:

 

08:55:29,669 ERROR [STDERR] 25/03/2011 08:55:29 AM sun.rmi.transport.tcp.TCPTransport$AcceptLoop executeAcceptLoop

ADVERTENCIA: RMI TCP Accept-4446: accept loop for ServerSocket[addr=/127.0.0.1,port=0,localport=4446] throws

java.net.SocketTimeoutException: Accept timed out

        at java.net.PlainSocketImpl.socketAccept(Native Method)

        at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:390)

        at java.net.ServerSocket.implAccept(ServerSocket.java:462)

        at java.net.ServerSocket.accept(ServerSocket.java:430)

        at sun.rmi.transport.tcp.TCPTransport$AcceptLoop.executeAcceptLoop(TCPTransport.java:369)

        at sun.rmi.transport.tcp.TCPTransport$AcceptLoop.run(TCPTransport.java:341)

        at java.lang.Thread.run(Thread.java:662)

 

Somebody said to set the log level to 'Error', but this is no a solution here, since as you can see, this already as the 'Error' category. Also, setting the log level to 'Severe' isn't a solution for our project either, we need to see other errors.

 

Does anybody know why this happens?

Does anybody know how to prevent this from happenning?

 

Thanks

  • 1. JBoss 4.2.2GA Error with RMI: Accept timed out
    Paul Dwinnell Newbie

    I get the same error when using the RMI transport.  I get it every 60 seconds which I believe is based on one of the timeouts in the config.  It does not seem to create a problem with my remoting which works alright.  But, of course I don't want to assume it's a non-issue.   I too saw someone on one of the forums trying to change the logging to hide this error which seems the same as sweeping it under the rug ;-)

     

    Additionaly, when I use other transports such as HTTP or Socket I don't get the error.  I would also be interested if anyone knows what's causing this, whether it's a problem and if there's a way to fix it.

     

    thanks